0 Replies Latest reply on Mar 26, 2020 10:03 AM by Bill Bass

    DateParse no longer works after upgrading from 10.4 to 10.5, extract refresh fails

    Bill Bass

      I have a Tableau Workbook package that refreshes from a MS SQLServer. This worked fine until I upgraded from 10.4.20 to 10.5.25. Now when I perform the Refresh All Extracts, I get an error for one of the tables that includes a Tableau calculated field, 'Invalid field formula due to limitations in the data source'. I went tot the table that failed in the extract, and noticed that in the formula for the calculated view, it says 'The calculation is invalid'. This is the formula that I'm using:

      DATEPARSE("M/d/yyyy h:m a",[Date Time])

       

      The [Date Time] field is a string type field that comes from the SQL Server database and the date is in the following format:

      1/1/2002  1:00 AM

       

      I cannot seem to find any documentation on this issue. But all I know is that this worked fine under 10.4, but now under 10.5 it doesn't work. I attached the Tableu Workbook package to this post. All data is contained within the package.

       

      Bill Bass