2 Replies Latest reply on Mar 24, 2020 7:42 PM by Vivek Pant

    Tableau Prep - 'Publish as a data source'

    Vivek Pant

      Hi community,

       

      Can someone kindly guide me and help in resolving one issue I am facing. The process is very simple. I am just reading an excel file, doing some calculations and then publishing it as a data source to server so that I can then connect to that data source from Tableau Desktop and do further analysis (FYI, our network drives connectivity is disabled on our server and hence we can not directly connect to excel files).

       

      The simple workflow is like this:

       

       

      Now when I ran this flow the data source is published to the server. I tried to connect to that from the Tableau Desktop and I was able to successfully connect to it. Screenshot of server:

       

       

       

       

      I am able to get the data in the desktop, so I assume the data source on the server was created as 'Extract' from Tableau Prep? The issue is when I build a dashboard using the published data source and publish that to server, it is failing with an error:

       

       

      I am not sure why is this the case. Kindly help.

       

      Regards,

      Vivek

       

      PS: I used Tableau Prep 2019.3.2 and my server is running on 10.3.11

        • 1. Re: Tableau Prep - 'Publish as a data source'
          Eduardo Moreno

          Hi Vivek,

           

          In order to fully get the potential of Tableau Prep you need to update your server to version 2019.3 or above (Tableau Prep intended to work with Version 2019.3 or above). In version 10.3.11 Tableau extracts were created as .tde, but starting from 10.5 Tableau extracts changed to .hyper format which is more efficient.

           

          I believe the difference in extract formats is the reason you are getting this error.

           

          Another thing you can do is, using Tableau Desktop v10.3, you can create an extract from your data source and publish it directly to server.

           

          Regards,

          Eduardo

          • 2. Re: Tableau Prep - 'Publish as a data source'
            Vivek Pant

            Thanks a lot Eduardo. I have 2019.3 version in our UAT Environment (being tested for PROD). I tried to create the workflow on that version and it worked completely fine. Cheers.