1 Reply Latest reply on Dec 2, 2019 9:35 AM by Nathan Mannheimer

    Installing Tabpy Server: tornado-json 1.3.4 has requirement jsonschema<3.0

    pari p



      I'm using Jupyter notebook and I wanted to deploy a python function to the tabpy server and got the below error while installing tabpy server "pip install tabpy-server"


      ERROR: tornado-json 1.3.4 has requirement jsonschema<3.0,>=2.3.0, but you'll have jsonschema 3.0.2 which is incompatible.

      ERROR: tornado-json 1.3.4 has requirement tornado<6.0,>=3.2.2, but you'll have tornado 6.0.3 which is incompatible.


      So, I tried to downgrade json to 2.6 and another error popped up which said Jupyter notebook required a json version > 3.0


      This is a deadlock and I wanted to know if anyone faced this issue and also any pointers on how to deploy a function to tabpy server from jupyter notebook.