3 Replies Latest reply on Oct 10, 2019 1:50 AM by Ciara Brennan

    Building a Web Data Connector, Fetch Data Table Not Appearing in Simulator

    John Emery



      I have been tasked with creating a WDC for a client's API. I have no experience building WDCs, and practically no experience coding in JavaScript.


      I have been following the tutorial step-by-step, and it had been going okay until the point where I tried to fetch data. With the earthquake example a table appears right away, but  when I try no table even appears. Looking at the structure of the earthquake data versus mine, I can see that there are some differences, so I think the issue must lie in my JavaScript code. Unfortunately, my lack of experience is making it very difficult for me to even know where to look to fix any bugs I run into.


      Here is a snippet of how my data is structured:

      {"result":{"message":"Success","result":[{"first Name":"Jay","last Name":"Bobo","role":"CEO",....}


      I have attached a sample of my JS code to this post.


      Finally, below is a screenshot of the WDC Simulator after I press the "Fetch Data Table" button. As you can see, the column metadata appeared properly, but nothing populated for the data table as it does for the earthquake example.

      Fetch Data Table.png

      If anybody can help, or nudge me in the right direction, it would be tremendously appreciated.