8 Replies Latest reply on Sep 12, 2019 11:47 PM by frederic.spielmann.0

    TSM issue

    leela chaitanya
      Hello Everyone, My tableau server's tsm utility is not accessible and the server is down...restarted the services in all 3 nodes still no improvement. 

       

       

      in tsm.log file : TsmAdmin controller didn't return a Tsm response

       

       

      Internal Server error - 500 

       

       

      in Tabadmin controller node 0-1.log file : 

       

       

      2019-09-10 14:22:16.439 +0100 Thread-1-SendThread(<node1 IP>:8782) : INFO org.apache.zookeeper.ClientCnxn - Opening socket connection to server <node1 IP>/<node1 IP>:8782. Will not attempt to authenticate using SASL (unknown error)

       

      2019-09-10 14:22:16.439 +0100 Thread-1-SendThread(<node2 IP>:8782) : INFO org.apache.zookeeper.ClientCnxn - Opening socket connection to server <node2 IP>/<node2 IP>:8782. Will not attempt to authenticate using SASL (unknown error)
      tsm error.PNG

       


       

      Please suggest the solution...
        • 1. Re: TSM issue
          Jeff Strauss

          It's hard to say, but one suggestion may be to reboot all 3 nodes and see if this helps.  Also, have a look at each of the windows event viewers to see if it shows any useful info.

          • 2. Re: TSM issue
            leela chaitanya

            Hi  Jeff Strauss,

             

            Thanks i can see the below errors in Event viewer. what should i've to do now?.. Please suggest

             

            In Services.msc all 6 services are running fine. in additional nodes i've 3 services in each server and they were started.

            • 3. Re: TSM issue
              Jeff Strauss

              it seems like something is awry with your gateway service.  Did you try a reboot?

              • 4. Re: TSM issue
                leela chaitanya

                Yes i've done with reboot still no luck.  i can't access tsm UI/cli. not sure how to overcome this issue.

                 

                In additional 2 nodes i've all 3 services started and they are running fine.

                • 5. Re: TSM issue
                  Jeff Strauss

                  Can you open a support case?

                  • 6. Re: TSM issue
                    frederic.spielmann.0

                    Hi Leela,

                     

                    When going on TSM Web UI, what's the state of the different process ? https://yourTableauServer:8850

                     

                    1. Is any hosts were running out of space ?
                    If yes, have a look to the following article : Tableau Server in Error/Degraded State after Running out of Hard Drive Space or Increasing Drive Space

                     

                    2. On Windows Server, go to "services", and check if all Tableau Server services are started.

                    Verify Tableau Service Settings

                     

                    12-16-2018+1-47-22+AM.png

                     

                    3. Check the host entry (in the windows hosts file) and the IP Address of the machine are the same.

                     

                    Otherwise as Jeff recommended, it's maybe better to open a support case.

                     

                    Kind regards,

                    1 of 1 people found this helpful
                    • 7. Re: TSM issue
                      leela chaitanya

                      Thanks!!   unknowingly someone has enabled the firewall. After disabling the firewall issue was resolved

                       

                      Now i'm facing another issue...In Additional Node2 when i enter

                      > tsm status -v

                      Could not connect to TSM Controller at '<node name>:8850'.

                       

                      Please suggest..

                      • 8. Re: TSM issue
                        frederic.spielmann.0

                        Hi Leela,

                         

                        The error "Could not connect to TSM Controller at '<node name>:8850'." could be related to different issues :

                         

                        1. If the hostname of the server has been changed (Most of the time, and could be confirmed in "tsm.log" file).

                             Quick explanation: When installing Tableau Server, a TSM SSL Certificate will be generated. No change could be made manually on this Certificate. If the      hostname changed, it will not match anymore the "hostname" from your TSM Controller SSL Certificate, and the connection to TSM could not be made      anymore.

                             a. Use the previous hostname

                             b. A reinstallation of Tableau Server will be necessary to recreate a new TSM Controller SSL Certificate (unfortunately there is no other way at the moment).

                         

                        2. If the TSM Controller SSL certificate's expired (Mostly Tableau Server 10.5.x on Linux)

                             a. Open a command prompt as administrator and move to the Gateway/Apache folder of your Tableau Server, you should found the "OpenSSL" tool.

                             To check if the certificate expired, run the following command :

                                  openssl s_client -connect servername:8850

                                  echo | openssl s_client -connect servername:8850 2>/dev/null | openssl x509 -noout -dates

                         

                        3. Check if the port 8850 is not blocked in the firewall :

                             in a command prompt: telnet localhost 8850

                             If it's not blocked, you should received : "Connected to localhost"

                         

                        4. Check if all Tableau Server services are started (See my previous message)

                         

                        5. You can also have a look in "tsm.log" file for the root cause, the default location is : C:\Users\<user>\.tableau\tsm

                         

                        Kind regards,