6 Replies Latest reply on Jun 14, 2019 11:07 AM by brian.oilar

    Unable to Create Initial Administrator Account - LdapSearchException

    brian.oilar

      Doing a new Tableau Server remote install and have been unable to create the administrator account.  When I run this command I get the following error:

       

      C:\Windows\system32>tabcmd initialuser --username "ABCD\myserviceaccount-name"  --password "xxxxxxxxxxxxxxxxxxxxxxx" --friendly "Tableau Admin" --server http://localhost:443/

       

      I get the following error:

       

        *** Internal server error

      LdapSearchException

       

      The server itself works with active directory no problem.  I'm able to log into TSM and was able to assign the Run As user account with no issues with 2 different accounts in the AD group.   Have tried the initaluser command with 2 different accounts and both generate that error.

       

      The server is installed on the D: drive.  The system is installed on C:    I tried following the steps in the KB Verify Folder Permissions, but that didn't help anything so I backed out of the changes.    The person that I pester in our IT department said that shouldn't matter because the AD group that this account is a member of has admin rights to everything on the machine.  

       

      Quick update.  I was looking through and error log for the gateway and came across several instances of this going all the way back to the install yesterday morning: 

       

      [Thu Jun 13 09:34:31.475326 2019] [ssl:warn] [pid 4588:tid 404] AH01916: Init: (localhost:443) You configured HTTP(80) on the standard HTTPS(443) port!

       

      I wonder if that might have something to do with this situation.  I set 443 during the install b/c our IT dept said that this is what how the load balancer will communicate.   Tried switching this back to 80 using tsm topology set-ports and rebooted the server.  The change didn't take hold though.

       

      Message was edited by: Brian Oilar