5 Replies Latest reply on Mar 11, 2020 12:37 PM by BK Trehan

    Tableau online refresh doesn't work with Snowflake.

    Steve Brownell

      I'm facing a weird challenge. We connect to our Snowflake instance via SAML/IDP (Okta) on Desktop. And when we publish the workbook it works great. Each analyst/Data scientist uses their own SAML login and 2FA to access the data on Desktop and publish to Server.

       

      However, when Tableau Online goes to refresh the extract, it always fails with this error message after 7205 Seconds:

      com.tableausoftware.nativeapi.exceptions.TableauCancelException: Operation cancelled. Could not complete the extract refresh task because it exceeded the timeout limit. Possible reasons include: extract data source is too big, network connection is slow, insufficient resources available on the external database, insufficient resources available on the server, etc.

       

      Many of these refreshes take only a few seconds when I do them manually. This happens for everyone at the company. It's possible this is a snowflake issue too, but I can't figure it out.

        • 1. Re: Tableau online refresh doesn't work with Snowflake.
          Carisa Chang

          Hi Steve,

           

          You'll need to open a case with Tableau Support so they can look at the Tableau Online logs and help figure out why this refresh is exceeding the 2 hour timeout on Tableau Online.

          • 2. Re: Tableau online refresh doesn't work with Snowflake.
            Sebastian Sofariu

            Hi Steve,

             

            I did a bit of research on this error and I discovered an instance displaying a similar behaviour with Tableau Online failing to refresh Snowflake datasource using Okta SAML with "externalbrowser" as the SAML IdP(Okta) URL after 7200 Seconds.

             

            If this is the case,  possible workaround is to replace "externalbrowser" with the URL for the SAML IdP Server and republish the data source.

             

            For more information, please refer to the Snowflake online help article.

             

            The possible workaround aforementioned is based on the knowledge base article below.

             

            Error "Tableau Online can't connect to the following database" Or "The specified authenticator and destination URL in Saml Assertion did not match" Publishing Live Snowflake Data Source Using SAML

             

            Please note that using "externalbrowser" is only expected to work in Tableau Desktop, and is not officially tested or supported

             

            I hope this information help.

            • 3. Re: Tableau online refresh doesn't work with Snowflake.
              Bheem Aitha

              Hi Steve,

               

              I am facing a different issue while publishing a Snowflake data source to Tableau Server. I am able to connect to Snowflake using SAML Idp (OneLogin) authentication and I am using externalbrowser option. I was able to see the data from Snowflake in Desktop but while publishing to Server it just hangs forever and finally fails. I see that you are able to publish it and would like to know whether you faced the same issue. BTW, I tried in 2018.2 and 2019.2 versions and both had similar issue.

               

              Thanks

              -Bheem

              • 4. Re: Tableau online refresh doesn't work with Snowflake.
                Carisa Chang

                Hi Bheem,

                 

                In the article on using "externalbrowser" - you can see this is not expected to work on Tableau Online or Tableau Server - using MFA is not an officially supported feature:

                 

                Cause

                Using "externalbrowser" is only expected to work in Tableau Desktop, and is not officially tested or supported

                • 5. Re: Tableau online refresh doesn't work with Snowflake.
                  BK Trehan

                  It looks like this issue has come up again. When trying to refresh an extract from Snowflake on Tableau Online, I'm getting the following error:

                   

                  com.tableausoftware.nativeapi.exceptions.DataSourceException: [Snowflake][Snowflake] (25) Result download worker error: Worker error: [Snowflake][Snowflake] (4) REST request for URL [SERVER URL] failed: CURLerror (curl_easy_perform() failed) - code=91 msg='SSL server certificate status verification FAILED'.

                   

                  We have Snowflake on Azure. A few things we tried:

                   

                  - Extracts are working when done locally on Tableau Desktop

                  - Server credentials are working when using "Test Connection" on Tableau Online

                  - One small extract is completing refresh, but all others are failing

                   

                  We reached out to Tableau support and they think it's a Snowflake issue. Just received an email from Snowflake support that says:

                   

                  "There is an on-going network issue with Azure OCSP services which the Snowflake drivers use to check certificate revocation status as part of the authentication.

                  Due to this failure the drivers are unable to successfully connect. 

                  The latest Snowflake drivers are able to circumvent this issue by using a fallback method that skips this check temporarily.

                  We advise to upgrade to the latest version available from https://sfc-repo.snowflakecomputing.com/odbc/index.html.

                  It’s possible that retrieving larger result sets (over 1 MB) fails, while smaller queries return successfully.If for some reason this continues to fail, we’d like to obtain the most recent ODBC logs for investigation (https://community.snowflake.com/s/article/How-to-generate-log-file-on-Snowflake-connectors)."

                   

                  Looks like there is a driver issue occurring. Working with our SE to figure out next steps, but I think the drivers need to be updated on Tableau Online by the Tableau team.

                   

                  Anyone else having this issue?