1 Reply Latest reply on Feb 4, 2019 1:55 AM by Norbert Maijoor

    Trend issue on graph when no data

    Amar Amar

      Hi ,

      I'm struck with one issue. Please see the attached workbook and let me know your thoughts.

       

       

      In the worksheet 2, when I filter data based on category, no data for year 2 , but since my table calculation is looking for previous year it is not able to read year 2 but looking at year 3 and giving me wrong percentage.

      Correct value i'm trying to get is -37.3 as in worksheet 1

      Please advice. (show missing values is not helping here)

       

      If i have data no issue, but when no data available , I'm struck.

        • 1. Re: Trend issue on graph when no data
          Norbert Maijoor

          Hi Amar,

           

          Find my  approach based on a "scaffold"-dataset stored in attached workbook version 10.5 located in the original thread.

           

           

          1. Define a Scaffold-dataset

           

           

          2. Define the Scaffold dataset as primary dataset

           

           

          3. Define D1. Date based on de primary dataset: DATE(DATEPARSE ( "MM-dd-yyyy", '1-1-'+str((2015 +[Year ID])) ))

           

          4. Define M1. Value: zn(SUM([Sheet1 (rawdata)].[Value]))

           

          5. Drag the required objects to the indicated locations

           

          Amar.jpg

           

          Hope it helps,

           

          Regards,

          Norbert