1 Reply Latest reply on Jan 4, 2019 8:16 AM by Jeff Strauss

    Unable to publish extracts - Error message: Unable to delete directory

    Natalie Olson

      My application has 9 data sources. All extracts from SQL server.

      The application was originally created in August, and has been published and re-published since late Aug-early Sept.


      I have always published the application by publishing the data sources separately.

      Then, in late-November, I started getting an error when attempting to publish four of my data sources

      Ex: Census, HospitalPayments


      In desktop the error says it's a run time exception.

      Runtime Exception.png

      Error Message.png


      In the logs, it looks like this:

          2018-12-19 15:08:03.279 -0500 (Default,olsonnc@core.umdnj.edu,iUa88PELQOy6UPCtXNNK0g,XBqlIbDn0Fdbq33M-ZXZngAAASU,0:-6262429d:167c790fca4:-7dfd) pool-21-thread-1 vizportal: ERROR com.tableausoftware.domain.publishing.service.PublishingService - Failed async job: Publish Datasource


      java.lang.RuntimeException: java.io.IOException: Unable to delete directory C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract\a6\7e\{2E2EEE79-6C6A-43D8-BD9A-C239FE262702}_TDFSTRNSFR.


      I am able to publish all the data sources embedded. But, I can no longer publish the four separately.


      I have a dev/val site, and a separate production server, and I'm not able to publish these extracts to any of them. I tried renaming them, deleting them from Tableau Server, publishing from a separate workbook. Nothing seems to work.

      We've also tried restarting and reindexing Tableau server and emptying the Desktop cache.


      Also, checked security and nothing about my security has changed from when I was able to publish. And I'm a server admin.


      The last time I published successfully, there were no changes to these four. The changes were the addition of the Budget data source and I think we added a flag to Provider Accessibility.


      Has anyone run into this before?

      Or have any idea how we might fix it?

      Or anything else to try?