2 Replies Latest reply on Dec 15, 2018 3:01 PM by Ken Flerlage

    how to create an arc diagram in tableau

    Jesse yung

      I'm following this tutorial step-by-step but didn't get the expected result. Anything went wrong in my attached workbook?

        • 1. Re: how to create an arc diagram in tableau
          Ken Flerlage

          I've seen it happen before where something just seems to go haywire when using bins to perform this data densification. There seems to be no rhyme or reason to it, but sometimes the bins just won't work properly with the index table calculation. When that happens, I typically just recreate the bins field then try again. I did that with your workbook and viola, it worked. It's strange and I've yet to find an explanation.

           

            

           

          One thing I like to do, before jumping into the more complex stuff, is to make sure the data densification via bins is working. To do that, I do the following:

           

          1) Create the bins.

          2) Drag my dimensions & bins to the detail card on a new sheet.

          To help visualize it, you can drag something to the color card. I'm using Step in this case:

          We now have two squares for each step, as expected since that's what's in our data.

           

          3) Drag index to the detail card and set it to compute using the bins field. When you do that, you should see it create many more squares as shown below. There should be one square for each bin (in this case, 181).

          If you do this and do not see a bunch more squares, that's an indication that something has gone wrong, as shown below with your original bins field.

          Again, my only solution to this is to recreate the bins filed and try again. But once you have this part working, the rest should work as expected.

          • 2. Re: how to create an arc diagram in tableau
            Ken Flerlage

            Update. I just asked around about this problem since I experience it from time to time and I got a good answer from Christopher DeMartini. It seems that, for whatever reason, the bins field is sometimes being set to "Show Missing Values" and, at other times, it's not. There doesn't seem to be any rhyme or reason to this, but that setting is critical for data densification to work properly. Chris's solution is as follows:

             

            1) Drag the bins field to the rows or columns shelf.

            2) Right click on the pill and choose "Show Missing Values"

            3) Remove the pill.