3 Replies Latest reply on Apr 15, 2019 7:21 AM by Patrick Murphy

    Salesforce Integration

    Kelly Dwyer

      Hi. I'm undertaking my first attempt at a Tableau/Salesforce integration. I want to be sure it will do what I need it to do before I present it as an option to my client. I tried to set up a test with my Tableau account and free Developer org but it doesn't seem to allow me to refresh (where you would typically be able to schedule or push refresh in Tableau it is greyed out). I also tried with a live instance and had the same issue ... I *think* I might have to enable some of the API settings - Tableau instructions seem to allude to this but there is nothing specific about how to enable these.

       

      Has anyone done this who might be able to point me to some resources I could use? Thanks!

        • 1. Re: Salesforce Integration
          Sasha Hanna

          Hi Kelly,

          Did you set up a connection following these guidelines Salesforce - Tableau? Where you able to drag a table onto the canvas? Tableau only supports extracts so it will force you to create one and only once this is created will you be able to refresh.

          Cheers,

          Sasha

          • 2. Re: Salesforce Integration
            Kelly Dwyer

            Thanks for the reply!

             

            Yes, I did. It is all working fine in terms of my data is there, and I am able to create the visualizations I want. And it says, 'extract created (the date I created the workbook) -  I am just not able to refresh it ... the button for refresh is greyed out see screenshot below) and when I go to Data - > Refresh Datasource nothing seems to happen. Also everytime I close the workbook and reopen it and try to access the data, it tells me to log in to salesforce again which is another reason I think it's something to do with the API settings in Salesforce???

             

            Screenshot 2018-12-03 10.20.20.png

            • 3. Re: Salesforce Integration
              Patrick Murphy

              Sorry to jump in, did you manage to connect Salesforce properly and were you able to drag objects onto the canvas. I am stuck with trying to pull in my data, I have left it running for upwards of 6 hours and it continues to fail.