3 Replies Latest reply on Oct 1, 2018 7:26 PM by Naveen B

    Tooltip not showing alias values for some Dimensions ...

    Joseph Pollard

      I've got a bit of a mystery on my hands and I've searched online and the forums with no solution (yet).

       

      I have a view in which I have a handful of Dimensions that I want to include in my Tooltip (Tableau Desktop vers. 2018.2).  The data are currently formatted as "percentages" (i.e., as a Discrete Number) because I don't need to perform any analysis, but just include them into a Tooltip.  Each of these measures has a number of Null values and I want those to display as "N/A" in the Tooltip ... so, I created an alias for Null ... to be "N/A"

       

      This worked for 6 of my 8 Dimensions ... but 2 Dimensions are just showing up blank in my Tooltip rather than displaying as "N/A."  I do have one dimension that is formatted as a continuous # dimension and it's displaying the "N/A" just like the other discrete # dimensions ... and when I tried to change it from continuous to discrete it no longer showed the "N/A" alias ... so I changed it back ... but it's odd to me that just doing that conversion made it stop showing the alias in my Tooltip. I checked them both to make sure they were formatted just like the other 6 and as far as I can tell they are formatted the same (but I may have missed something subtle).

       

      Anyway, I've attached a copy of the view (it's a map and the Tooltip should pop up when you hover over a school location).  The data are not confidential or anything, but they are not finalized so please don't use them or display them for any reason.  Once we finalize the dashboard and verify the underlying data they will be available on the Idaho Division of Public Health Tableau Public profile page in case you are interested.

       

      If anyone can help me sort this out ... you will be my new Tableau Superhero (I realize it's not much, but I don't give that title out to just anyone). ;-)

       

      Cheers!

       

      Joe