7 Replies Latest reply on Sep 19, 2018 1:26 PM by Jonathan Seiden

    "Invalid field formula due to limitations in the data source." on Tableau Public with .xlsx

    Jonathan Seiden

      I've seen this error on the forums quite a bit, but not with my situation. I'm getting this error using Tableau Public 2018.1 and 2018.2.

       

      An error occurred while communicating with data source 'Sheet1'.

      Invalid field formula due to limitations in the data source.

      Unable to create extract

       

      I created a Tableau template that I've been using for over a year now here: Tableau Public

       

      Each time I want to create a new viz, I clean data locally and create a new .xlsx with a prespecified format. Then I open my template from Tableau Public, "Edit Connection", and link it to my new xlsx before making some cosmetic polishes and "Save as" to Tableau Public.

       

      I just tried to create a new viz with this workflow and am running into this error and cannot resolve it. I've even tried relinking data that is already on the Tableau Public site (e.g. this viz: Tableau Public that worked before) and am getting the same error.

       

      Note that the template has fields that not all my datasets have, so some visuals (e.g. Tableau Public ) only exist for some datasets. This had never been a problem before, as I only published the views that actually got populated, and all the vizzes are working fine locally, but I cannot save them to Talbeau Public.

       

      Any ideas how to solve this, and why am I being asked to create an extract at all? Isn't that only for server data? As far as I can tell, it's not even possible when working with an XLS. As you can see below, I don't apear to have this option

       

      In my Googling, I've investigated the following issues which haven't worked for me:

       

      -Removing all fields with a red ! (and any worksheet or dashboard that references them)

      -Replacing "integer" with "decimal" on numeric values

      -Checked my data for "date", nothing there

      -Checked my data for weird XML, nothing there

       

      Any ideas? Thank so much in advance!