2 Replies Latest reply on Sep 16, 2018 11:49 PM by Caleb Heath

    Tableau can't return results from a query that still works in Tableau on another machine

    Caleb Heath

      So im at a loss with this one,

       

      Got a new works laptop and started having issues with some queries in Tableau.

       

      When I run my query in SQL Developer I have no problems and this query ran just fine in Tableau on my old laptop creating an extract with data inside, however now when I run this query on my new laptop SQL Dev is still fine however tableau runs it with no errors but doesn’t return any results when creating the extract or when set to live.

       

      I have tried multiple versions of tableau (10.1.1, 10.1.18, 10.4.1) installing and uninstalling each as I went and downloading and installing the appropriate drivers for connecting to oracle.

       

      I ran each tables in the query and they all ran fine except 1, so im wondering if its something to do with that table and the way tableau interacts with it when it queries it but I haven't had an issue before now, its only since i got my new laptop and reinstalled tableau.

       

      Any ideas?

       

      Thanks

      Caleb