3 Replies Latest reply on Jul 5, 2018 7:17 AM by Michael Gillespie

    tableau Server restart takes very long

    philipp.spannagel

      Hello,

       

      we are running the newest version of tableau server (2018.1) on a EX40 machine hosted at Hetzner, that is a Intel® Core i7-4770 Quad-Core at 3.4 GHz with 32 GB DDR3 RAM. We're using Windows Server 2016 Standard.

      The machine has other applications installed but the CPU was hardly above 3%. Then we installed tableau.

      Restarting tableau server is super slow. It takes about 15 minutes. During restart CPU usage rises a lot, sometimes it's at 100% for several minutes.

       

      Is this normal?

       

      Thanks, Philipp

        • 1. Re: tableau Server restart takes very long
          Michael Gillespie

          Philipp, is this a production server?  How much load is on this machine (how many dashboards/data sources/users)?

           

          This is underpowered for a production machine.  32GB for Windows Server plus other things PLUS Tableau is not going to be a fast machine.  Tableau really wants to be the only application on the server.

           

          And that i7 processor is definitely going to be slow in that configuration.

           

          Can you tell from the boot logs what's taking so long?

          • 2. Re: tableau Server restart takes very long
            Jeff Strauss

            Have a look at the tabadmin.log to see why it's taking so long.  We recently upgraded to 10.5 and saw some slow down when doing a tabadmin restart, it used to take about 5 minutes prior to the upgrade, now it takes about 15 minutes, it wasn't enough of a reason for us to hold up the upgrade, but when we looked in the logs, it appeared that some events were being done multiple times (i.e. checking of licenses).

             

            Also, take point to MG's comments, Tableau should be the only thing running on this box.

            • 3. Re: tableau Server restart takes very long
              Michael Gillespie

              Jeff, poke around for information on cleaning up old license versions.  I forgot about that issue: the change in license format that was introduced with 2018.1 can cause some issues if old/trial license information is hanging around.

               

              I've seen this be an issue with Desktop, but it might be the case with Server as well...