3 Replies Latest reply on Jun 11, 2018 10:33 AM by Ken Flerlage

    Unable to load workbook (either via Tableau Public or workbook file)

    Jason Kim

      Hi there,

       

      I saved a Tableau project 2 days ago and it works correctly on my Tableau Public profile but when I try to open it in Tableau public either from a workbook file or the "Open from Tableau Public..." dialog, I get the following error:

       

      Unable to complete action

      Errors occurred while trying to load the workbook "D:\Google Drive\Data Analysis\Practice Sets\New Collision Data Profiler.twbx". The load was not able to complete successfully.

       

      Error(1609,30): element 'analysis-fields' is not allowed for content model '(field+)' (id: C:\Users\Jason\AppData\Local\Temp\TableauTemp\3653171824\New Collision Data Profiler.twb)

       

      I've tried looking into the temporary path it references and there isn't a path or file there (I've also tried putting the workbook file at that path to no effect).

       

      This is frustrating since I spent many many hours with those visualizations and they're now in a unmodifiable state since I can no longer edit or load the file. Any help on this would be GREATLY appreciated! I think the problem may have been caused by having the viz open on my laptop and desktop at the same time though I can't be sure.

       

      I've attached the workbook and also the link to the viz on my Public profile for reference:

      https://public.tableau.com/profile/jason.kim7629#!/vizhome/NewCollisionDataProfiler/PedestrianCollisionEventsbyLocationandInjuryJittered?publish=yes

       

      Thanks,

       

      Jason

        • 1. Re: Unable to load workbook (either via Tableau Public or workbook file)
          Ken Flerlage

          A twbx file is essentially just a zip file that contains both the workbook (twb) and the data (in your case, a hyper extract). And a twb is just an xml file. My guess was that the xml was somehow corrupt. I extract the twb and hyper file from the twbx, then opened the twb with a text editor. I searched for "analysis-fields" in the XML and removed the entry referring to it. I saved and reopened and got a few additional errors. In the end, I removed the following highlighted text:

           

           

          After doing that, I was able to open the twb file. I reconnected it to the extract, saved it as a packaged workbook, and attached it here.

           

          Please note that this hacking of the XML could cause other problems down the road, but I hope that's not the case.

           

          If this addresses your issue, please be sure to mark this answer as correct. Thanks!

          1 of 1 people found this helpful
          • 2. Re: Unable to load workbook (either via Tableau Public or workbook file)
            Jason Kim

            Thanks for this Ken.

             

            This solution didn't work within Tableau Public itself (when opening your modified workbook, it says "A newer version is available on Tableau Public, do you want to load it now -- Yes or Cancel?") which just looped the error so what I did was use my school credentials to get an academic license of Tableau Desktop -- this allowed me to open the file like you say and save it on top of the existing, buggy workbook on Tableau Public (in the cloud).

             

            Thanks again!

            • 3. Re: Unable to load workbook (either via Tableau Public or workbook file)
              Ken Flerlage

              Awesome. I thought about that after posting because Tableau Public will always try to open the version that is on public, but glad you found a solution.