5 Replies Latest reply on Jun 21, 2018 1:54 AM by Olivia Shen

    Tableau Prep Outputs Empty Dataset

    Olivia Shen

      Hi All,

       

      I know Prep is quite new and not sure if anyone has ever had this same issue as I have.

       

      I have several outputs of a Prep flow, all with values but one. This output shows values as expected while rendering, but the actual output file has not values after I run the flow, only showing column names (see pics below).

       

      Output in Prep:

      Output as csv:

       

      I've tried different output types, but all gives empty data set. I also try to join this source with others to run the output, again, all columns from this source are just null.

       

      Really have no idea how it happens and it would be very much appreciated if someone could point out what the issue is.

       

      Olivia

        • 1. Re: Tableau Prep Outputs Empty Dataset
          Isaac Kunen

          Hi Olivia,

           

          That is... odd. You should definitely open a support case on this -- if we can get get our hands on a repro case, it will be much easier to figure out what's going on.

           

          When you run the flow, though, are you getting the usual run dialog, and does it indicate that it's producing rows?

           

          Thanks,

          -Isaac

          • 2. Re: Tableau Prep Outputs Empty Dataset
            Olivia Shen

            Hi Isaac,

             

            It has the usual run dialog, but completes in seconds not showing xxx rows generated.

             

            I might have figured out the reason, not sure if you could reproduce the error to have a fix. I've tried to output the flow after each step, and it works when I export the raw data. I then tweak the operations applied to step (Clean 8 in the pic above right after the raw data, and it seems that the "Keep Only" function results in the empty dataset. So I create a filter instead to serve the same purpose and the output is all good now.

             

            Keep Only does not work. The auto generated formula is (([FieldName] == "Value1" OR [FieldName] == "Value2"))

             

            Add Filter using another manner of calculation works good, and I'm using CONTAINS([FieldName]), 'Value1') OR CONTAINS([FieldName]), 'Value2')

             

             

            I'd like to test different formulas to see if it's because the operator or single/double quotes or something else, but just cannot afford the time to go through all the possibility. Hope the above explanation would help build a case.

             

            Olivia

            • 3. Re: Tableau Prep Outputs Empty Dataset
              Isaac Kunen

              Hi Olivia,

               

              Interesting -- and great detective work. What is/are your source system(s)? I ask because we'll generally try to push these operations down to the source system when possible, and so it could be that we have a problem in that logic.

               

              Thanks,

              -Isaac

              • 4. Re: Tableau Prep Outputs Empty Dataset
                Naoya Urata

                I am Tableau Employee though, encountered same issue. Keep Only didn't work. For me the source was Excel and CSV files.

                • 5. Re: Tableau Prep Outputs Empty Dataset
                  Olivia Shen

                  Hi Isaac,

                   

                  I have the same source type as Naoya, all involved in the flow are CSV files.