4 Replies Latest reply on May 9, 2018 8:36 AM by Dan Cory

    Tableau not opening files from NAS on Tableau Desktop Professional

    Rahul Kohli

      Hello Everyone,

                                This is Rahul and i would like to firstly say hi to everyone here, i am learning tableau and got into a strange situation today, The way i have setup my data and files is everything is available in my local Network access storage, so that i can change laptops if required.

      so in other words my Excel database file and tableau workbook file is all kept on Network drive locally and it was all working like a charm until few hours back, i slept and workup and found out Tableau is giving error when i try to open the relevant Workbook file (.twb)

      and here is the error code i am getting ...  ( fatal error (704,1) : comment or processing instruction expected ( id: Q:........\trial.twb) see pic below...

      Tableau NAS error.png

      I tried doing some troubleshooting myself by repairing tableau using my remove program feature on my windows 7 - didn't work

      then i completely uninstalled and reinstalled a latest version of Tableau Professional and tried opening my workbook- still didn't work

      to isolated the issue i tried to create a new workbook locally using locally kept excel file, it worked and still working fine, i created a new file using excel file kept on NAS and was able to do it, i saved the file in the same location on NAS - untill then it worked fine too, but as soon as i close Tableau and try and  open workbook again ( from NAS) same error!!! but locally kept file opens like normal.

       

      seems tableau can create workbooks and access data files on NAS  but unable to open them again once it quits and restarts

       

      please advise if anyone else has also faced this problem or what can be going wrong.

       

      P.S. I even tried to open workbook in notepad to try and figure out if any problem in xml code, but i am not much experienced in xml and don't know what am i looking for, also just recently newly created NAS files seems to be working and opening fine, but still unable to get my previous important workbooks to open.

      I have attached both files ( working and non working file) below

      Book1 --- recently created -- working

      Dognition_data_aggregated_by_dogidData --- imp file -- not opening

       

      Message was edited by: Rahul Kohli