2 Replies Latest reply on Apr 20, 2018 8:00 AM by Zechariah Starks

    Filtering subcategories on a dual axis viz using parameters

    Zechariah Starks

      I am trying to create a dual axis box and whisker plot where I select top level category, but give the user the option to select one or more subcategories. The idea is to show the user where the selected category/subcategory falls in the distribution of the data.

       

      To view all of my measures individually without aggregation, I pull my measure to the rows shelf and navigate to Analysis and uncheck Aggregate Measures. This step is crucial in achieving the visual I want.

       

      The viz I am trying to create is perfectly doable when there are no subcategories, because I am able to create a calculated field using an IF statement to set the value to the parameter's value. The problem is that when there are subcategories that I want additional filtering ability on, I have to use a copy of the datasource, which will always aggregate my measure in the copied datasource, regardless of whether or not  Aggregate Measures is checked or not.

       

      Is there a way to prevent Tableau from aggregating measures from a copied datasource? At this point, I think that is the ultimate issue I am encountering, but it could be something else. If it's something else. Please feel free to point it out.

       

      I have attached my workbook with sample data. The workbook is created to simply show that the copied datasource measure is being aggregated where I do not want it to be. If I can solve that issue, I should be able to provide the user with the ability to filter subcategories by pulling the Category and Subcategory pills onto the filters shelf, set the Category filter formula to the parameter value, show the filter for subcategory, and apply only relevent values.

       

      I'm using Tableau Desktop on 10.5. I'm not sure if this is an issue specific to 10.5 or not, but I couldn't find any related known issues to the 10.5 release.

       

      Thanks for the help!