9 Replies Latest reply on Feb 19, 2018 1:50 PM by Devin Brown

    Replacing a .tde extract with a .hyper extract is not allowed

    Devin Brown

      Hi all. We just made the jump from 10.4.x to 10.5. We only have a few analysts using Tableau desktop at the moment, without server, so we rely on extracts that are shared by copying the files to one another's computers. After upgrading to 10.5, I refreshed one such extract, and rather than replace the .tde, it made a new .hyper file. Ok. So I send the .hyper file to another associate and Windows (obviously) doesn't replace the .tde automatically when he copies it to his data sources directory, so Tableau doesn't automatically change to using the new .hyper extract when he opens his workbooks. I suggested something that has worked in best in the past, which is to delete the old extract, open the workbook, and upon getting the "can't locate extract" error go ahead and point it to the new .hyper file.

       

      No go. He gets a warning that says "Replacing a .tde extract with a .hyper extract is not allowed.". So outside of the server environment, what is the recommended course of action to update many workbooks that have been set up to use a .tde to use the new .hyper extract instead? The next option I'm aware of is to manually add the .hyper as a new source in the data window, and right click -> replace, but that is quite tedious and I've run into problems with calculations not pulling across correctly in the past. Surely there is a better way?