12 Replies Latest reply on Feb 10, 2018 2:17 AM by Ben Whitaker

    Extract refresh issue, possibly

    Justin Pulley

      I have a workbook, no I can't share it or the data, that I have published using an extract from a Redshift instance.  When I refresh the extract before publishing the file everything is fine, I can see the viz and it all works.  When I publish the workbook with the embedded extract and tell it to allow refresh access it publishes no problem and there is a schedule set for daily refresh.  Looking at the Background Tasks for Extracts at the extract for this workbook I see


      Task ID:  1141770

      Task:  Refresh Extracts

      Status of Task:  Success

      Created at:  2/8/2018 4:00:15 AM

      Started At:  2/8/2018 4:03:29 AM

      Completed At:  2/8/2018 4:03:39 AM

      Runtime:  10 sec

      Priority:  50

      Backgrounder:  localhost

      Backgrounder ID:  localhost:0:0


      Finished refresh of extracts (new extract id:{DE0C6ACF-E5B3-4708-B0B5-B1D09605F4A1}) for Workbook 'CPI RWK SLA 2017 and 2018'

       

      That seems to indicate that the refresh happened and there were no problems.  The issue is that the dashboard is blank.  Clicking the refresh data button doesn't fix it.  I don't understand why this is failing, but I would think the refresh should take a bit longer than 10 seconds as well.  I am having to republish this dashboard every day to make sure it works for the customer.  How can I nail down why the data isn't actually refreshing?

       

      before you ask - No, a live connection is not possible for a couple reasons; mainly the query takes 10+ minutes with live connection.

        • 1. Re: Extract refresh issue, possibly
          Vamsi Challa

          Does the Redshift credentials were provided to the TDE when published to server? Just to verify.

           

          Might be the firewall limitation of accessing Redshift. Just a guess.

          • 2. Re: Extract refresh issue, possibly
            Justin Pulley

            I would have assumed it uses the credentials I provide when I setup the data source in the workbook on publish, but I don't know for sure what it actually is doing.  In my mind what it would do is embed the data source connection info along with the data extract to the server on publish and the server would use that connection info I provided.  However, when I just checked the connection info it failed to connect to the server when I tested it and I had to manually update the password in the stored connection on the server to get it to connect; I tested the connection again to verify and it worked.  That indicates to me there is a major bug in the tableau software that is not publishing the connection information correctly, at least in this instance, for the password at the very least.  All the information, with the possible exception of the password, was correct.

             

            I will see what happens tonight for that refresh and if the data actually updates.  With the refresh saying it worked I never would have tested the connection.

            • 3. Re: Extract refresh issue, possibly
              Ben Whitaker

              Hello,

               

              I think Redshift needs a driver installed. Maybe you have it on your desktop, but the server doesn't. Not sure why it wouldn't throw back an error though... Do you refresh other redshift extracts from the server ok? If not, may be worth testing another extract on a test table or something.

               

              I take it you are actually using a server extract, and not publishing a packaged workbook and refreshing the workbook itself?

               

              If not, when you connect to the server version of the data source in a blank workbook, is the number of records being returned 0?

               

              Thanks,

              Ben

              • 4. Re: Extract refresh issue, possibly
                Justin Pulley

                Given the fact that I am the server admin and I installed the redshift driver myself 2 weeks ago, I can verify it has the redshift driver installed.  I haven't had anyone else that publishes say they have had this problem, but that doesn't mean they don't.

                 

                I am publishing a TWB with the options of data embedded and allow refresh access vice using the separate data source on the server.  That shouldn't matter though, the server should not be getting a bad password when I am publishing it that way.

                • 5. Re: Extract refresh issue, possibly
                  Vamsi Challa

                  Thanks for testing the connections.

                   

                  It would also help if you could "embedded the password in connection" in Server.

                  • 6. Re: Extract refresh issue, possibly
                    Justin Pulley

                    I did embed the password in the connection, unless you are telling me that choosing "allow refresh access" doesn't do that.  Which is why I am perplexed at why the server had a bad password when I tested it before changing the password.

                    • 7. Re: Extract refresh issue, possibly
                      Vamsi Challa

                      Any update on the extract refresh scheduled?

                      • 8. Re: Extract refresh issue, possibly
                        Justin Pulley

                        I am not sure what you are asking, but if you are asking if it is/was scheduled then the answer is yes.  The refresh is scheduled and does run with a "success" (Including early this morning), but the data is clearly not updated as the viz is, once again, blank.  The refresh says it took 25 seconds this time.

                        • 9. Re: Extract refresh issue, possibly
                          Vamsi Challa

                          Hi Justin, Thanks for the update. Still its confusing why viz is blank even after extract refresh is success.

                          • 10. Re: Extract refresh issue, possibly
                            Justin Pulley

                            My gut feeling is that it is not actually succeeding; I think it's not actually working.  Based on the fact that a live connection to the data takes 10+ minutes to execute the data retrieval, I would expect that the extract of the data would take at least that long + some to actually do the extraction piece.  The problem is I have no idea how to figure out what is going on with it.  looking at the logs is just going to show me a successful extract, but if you have some idea of what log might show something else; I'd be happy to look at them.

                            • 11. Re: Extract refresh issue, possibly
                              Vamsi Challa

                              Justin, Honestly I am new to Redshift connections.

                              • 12. Re: Extract refresh issue, possibly
                                Ben Whitaker

                                Hi Justin,

                                 

                                I would split the extract out fro the workbook initially for troubleshooting.

                                 

                                First of all open the server extract in a blank workbook. Check ow many rows are there. Refresh the data and check the new workbook for the rows again. If there are no rows, you know it is an issue with the server extract.

                                 

                                If there are rows there, go back to your original workbook after refresh. Check it has gone blank again. And then go into a visualization and start removing filters to see when data starts appearing. If data shows after removing certain filters, you know it is an issue with a specific filter.

                                 

                                At least if no data appears, you have narrowed it down to the workbook. Then we can take it from there.

                                 

                                Thanks,

                                Ben