4 Replies Latest reply on May 16, 2019 4:30 PM by Jarod Rollins

    Data disappearing from Table when filter added

    Stephen Fielder



      New Tableau User and first-time poster so please be gentle.


      In the attached workbook I'm finding data that should be visible is disappearing if I change the view by adding a filter.


      Example: See the Weekly Dashboard.

      With the filter showing all Programs visible, for Week Commencing 27 November 2017, Creative J under Program 5 reports Total Leads = 37.

      Change the Program Filter to show only Program 5 and you can see that all data for Week Commencing 27 November ceases to exist. I know there should be 37 Leads for Creative J, but these aren't displayed.


      I've followed various help topics to ensure I have my 2 key variables [Sent ] and [Total Leads ] wrapped in ZN(LOOKUP(SUM(<variable>),0)) so hopefully this isn't an issue with null or missing data not being replaced by 0s when appropriate.


      Do any of you helpful people happen to know what's happening here and how I can stop the data changing when the selective filter is applied?


      Many Thanks,



        • 1. Re: Data disappearing from Table when filter added
          Matthew Theis

          Hey Stephen Fielder I am able to replicate the issue.  What I was able to discover was that for some reason the Program Four Consent Program is the contributing factor.  November 27th disappears when this Program is not selected in the filter.  I see that [Sent ] has all 0 values for that time period, which at first I thought might have something to do with it, but because both Nov. 6th and Oct 30 have 0 in [Sent ] I don't really think that is the issue.  Also, another confusing point is that when I try to view all data, I get nothing but zeroes.  I wish I could help more, and perhaps my comments here can assist. 




          2 of 2 people found this helpful
          • 2. Re: Data disappearing from Table when filter added
            Stephen Fielder

            Hi Matthew,


            Thanks very much for looking at this for me - it's helpful to know that I'm not going mad and the problem is genuine and not just because I'm relatively new to Tableau.


            I've opened a support case with Tableau for this now I've worked out how to do this. They've replied to say that the problem could be because I'm using Data Blending rather than Joins to link my tables. So I recreated the table using joins, but I think I need a full outer join as there may be days when one or other of [Sent ] and [Total Leads ] doesn't have data points as nothing is recorded - e.g. Saturdays when we don't mail but do receive calls.


            It looks like full outer joins are only available for .csv data sources and I'm using an Access DB. So I'm a little stuck at the moment.


            I'll leave this open for now and see if anyone else can think of any good ideas.





            1 of 1 people found this helpful
            • 3. Re: Data disappearing from Table when filter added
              Matthew Theis

              Thanks for the info Stephen Fielder  Now that you say something, Blending does sound like the culprit.  Best of luck


              2 of 2 people found this helpful
              • 4. Re: Data disappearing from Table when filter added
                Jarod Rollins

                Hey Steve,


                I am a new user also and had this same problem. I was able to fix it, but don't know exactly why the solution works. In columns I had "year equipment was sold", in rows I had "equipment model" and I created a measure to count how many of a specific type of discount was issued. So that in the table it would show for Equipment model XX in 2019, 33 G9 discounts were applied. It worked great. then I duplicated the sheet and thought I would just change the discount in the filter to see what discount G7 looked like, everything would disappear. I found that I had some discounts that were labeled both G7 and G9 (ie. "Discount G7 in leu of discount G9") When I unchecked these in the filter everything worked. Again, I don't know why, but it fixed the problem. Hope that helps.