3 Replies Latest reply on Apr 10, 2018 3:18 PM by Jonathan Ficke

    Uncaught TypeError: Cannot read property 'length' of undefined

    Jonathan Ficke

      Hi, I getting the following error and I'm unable to debug.  Help is needed

      An unexpected error occurred. If you continue to receive this error please contact your Tableau Server Administrator.

      Session ID: 6A2760891C444A4DB1DF9E83260861FE-0:1

      Uncaught TypeError: Cannot read property 'length' of undefined

       

      A little bit about the error and when it occurs.

      • I've crated a sheet (graph) with three measures.
      • Each measure is an aggregate.
      • The graphs and filters work as expected in the desktop application.
      • However, when published on the Tableau Server, the error occurs when changing filters.  (Note: I only have one filter on my sheet).
        • When the error occurs, I hit "okay" and the data displays as expected.
      • I get the same error regardless of the browser I use.
      • I tried separating each of the measures into separate graphs (sheets), and the issue goes away.
      • I tried stacking the 3 separated graphs in a Dashboard, and the problem goes away.

       

      Conclusion:

      • The issue seems to be caused when having multiple aggregate measures in the same graph.  From a design perspective, this is what I want.  Any tips or ideas on how to fix the issue at it's source vs having to use work-a-rounds?

      Any guidance is greatly appreciated.  FYI: I'm on v10.3.