8 Replies Latest reply on Oct 31, 2017 6:38 AM by Ashutosh Jha

    Email not getting for VizAlert

    Ashutosh Jha

      Hi All,

       

      I am working on a VizAlert and have created simple workbooks to send emails if salary is more than $500k. I have added mine email id as the email to field and make the action 1.

       

      I published the workbooks on the tableau server and for testing made a comment but not getting any email.

       

      Can someone please help!

       

      -Ashutosh

        • 1. Re: Email not getting for VizAlert
          Matt Coles

          Hi Ashutosh. I recommend looking through the VizAlert logs to see what it has done. Do a search for a portion of the URL of the view you added the comment to, and see if it shows up. If it did not, then either VizAlerts is not running, or the comment was added incorrectly. If it did, then you should be able to see what happened from there. If you need more help, add another reply with the logs that show what is happening for that alert (but make sure to remove any sensitive information first!).

          • 2. Re: Email not getting for VizAlert
            Ashutosh Jha

            Hi Matt,

             

            Thanks for the quick reply. When you say the URL of the view does that mean the shareable URL of that view?

             

            I checked that URL on other system but the comment I made is not showing. Also, could you please let me know how I can check the log.

             

            Thanks.

            • 3. Re: Email not getting for VizAlert
              Matt Coles

              Right. Go to the viz you are building the alert on, grab maybe just the view name from the URL bar in your browser, e.g.

               

              https://server/#/views/SomeWorkbook/SomeView

               

              Maybe just grab the "SomeView" name. Search for that in the logs folder where you installed VizAlerts by opening up the text files there in a text editor program. Then just use Find to look for the view name.

              • 4. Re: Email not getting for VizAlert
                Ashutosh Jha

                Hi Matt Coles,

                 

                The log is something like below where view-2 is my view name.

                 

                {"ts":"2017-10-30T16:55:52.991","pid":12188,"tid":"23d8","sev":"info","req":"-","sess":"-","site":"{B78AE326-764D-4A06-B86F-DD6F42E54EC8}","user":"-","k":"command-pre","v":{"args":"tabdoc:rename-sheet new-sheet=\"View-2\" set-active=\"false\" sheet=\"Sheet 2\"","name":"tabdoc:rename-sheet"}}

                {"ts":"2017-10-30T16:55:52.992","pid":12188,"tid":"23d8","sev":"info","req":"-","sess":"-","site":"{B78AE326-764D-4A06-B86F-DD6F42E54EC8}","user":"-","k":"command-post","v":{"args":"tabdoc:rename-sheet new-sheet=\"View-2\" set-active=\"false\" sheet=\"Sheet 2\"","name":"tabdoc:rename-sheet"}}

                {"ts":"2017-10-30T16:55:53.052","pid":12188,"tid":"23d8","sev":"info","req":"-","sess":"-","site":"{B78AE326-764D-4A06-B86F-DD6F42E54EC8}","user":"-","k":"command-pre","v":{"args":"tabdoc:get-marks-color-uber-effects worksheet=\"View-2\"","name":"tabdoc:get-marks-color-uber-effects"}}

                {"ts":"2017-10-30T16:55:53.052","pid":12188,"tid":"23d8","sev":"info","req":"-","sess":"-","site":"{B78AE326-764D-4A06-B86F-DD6F42E54EC8}","user":"-","k":"command-post","v":{"args":"tabdoc:get-marks-color-uber-effects worksheet=\"View-2\"","name":"tabdoc:get-marks-color-uber-effects"}}

                {"ts":"2017-10-30T16:55:54.514","pid":12188,"tid":"23d8","sev":"info","req":"-","sess":"-","site":"{B78AE326-764D-4A06-B86F-DD6F42E54EC8}","user":"-","k":"command-pre","v":{"args":"tabdoc:navigate-to-sheet sheet=\"View-1\"","name":"tabdoc:navigate-to-sheet"}}

                • 5. Re: Email not getting for VizAlert
                  Matt Coles

                  These are not the VizAlert logs. These are from Tableau Server. Were you the person who installed VizAlerts, Ashutosh? If so, then go to the folder you unzipped it to. Within that folder will be a "logs" folder. Within it are the logs you are looking for.

                  • 6. Re: Email not getting for VizAlert
                    Ashutosh Jha

                    Hello,

                     

                    Are you pointing to the folder where I installed vizalerts.exe?

                    • 7. Re: Email not getting for VizAlert
                      Matt Coles

                      Yes, that is the folder I mean.

                      • 8. Re: Email not getting for VizAlert
                        Ashutosh Jha

                        Hello Matt Coles,

                         

                        Can you please share the steps to install (or any link where it is) so that I can verify. Seems vizalert.exe is not installed in my case.