6 Replies Latest reply on Jun 28, 2018 1:55 PM by Jen Shepherd

    Randomly have issues putting items in a layout container

    Luke Sirakos

      I don't know how to duplicate this so no workbook attached nor can I figure out a root cause but it has been happening to me throughout multiple versions of Tableau so it is not 10.4 specific.  There are times I will be building a dashboard and I will try to put an object in a container but Tableau just won't me do it. I typically notice it with filters but it happens with sheets sometimes as well.  I will have the object selected, it is not floating, and I will try to place it in a container but it is like wherever I move it the container just dodges it.  Sometimes I have gotten so frustrated I have just rebuilt the dashboard and it works fine.

       

      Has anyone else noticed this issue or know of a fix for it?

        • 1. Re: Randomly have issues putting items in a layout container
          Shawn Wallwork

          Yes Luke we have all experienced this phenomenon, unfortunately. I've noticed that it can be more difficult when dragging a tiled object (not floating) to another container. Instead, try floating the object first, then drag it into place while holding down the shift key. Make sure you wait for the grey box to appear before letting up on the mouse button. Hope this helps.

           

          Are you using Window or Mac? I've heard that Mac can be a little more fidgety. Don't give up you'll get the hang of it.

          1 of 1 people found this helpful
          • 2. Re: Randomly have issues putting items in a layout container
            Luke Sirakos

            I am on Windows, this has been something that has bugged me for years and I haven't found much of a topic on it. What ended up working on this latest issue was I moved the container I wanted to use to a totally different place on the dashboard and filled it up and then moved it in place.  Interesting enough, once I moved it in place I could not rearrange any of the objects without them falling out of the container but when it was in the original place I could rearrange them.

             

            It would be really nice if on the Layout tab under "Item hierarchy" if we could just drag items around there into the various containers/positions.

            • 3. Re: Randomly have issues putting items in a layout container
              Shawn Wallwork

              Yeah that would be a nice solution. There's an idea out there for this that you could vote for. If you make a video of you moving things around and getting stuck I'll take a look and see if I can suggest way to make it easier. But not sure there really are any, other than practice and  patience.

              • 4. Re: Randomly have issues putting items in a layout container
                Emanual Henry

                I'm not sure if you're describing the same issue I have, but here are some things I found help when dealing with containers:

                • If your container height is too small, it is impossible to drag anything into it.  Temporarily increase the size of the container.
                • If you want to place a container inside another container, drag a text box into the outer container.  Type the text "placeholder" or something.  Then drag your inner container.  This text box keeps the separation between the two containers and now you can drag more containers within it.  Delete the text box when you're done.
                • 5. Re: Randomly have issues putting items in a layout container
                  Luke Sirakos

                  Had this issue pop up again and I resized the container and it worked like a charm, thanks for the suggestion

                  • 6. Re: Randomly have issues putting items in a layout container
                    Jen Shepherd

                    This really vexes me, too!!  I'm chiming in on this old post in case someone else finds it like I just did.  A few other tips:

                     

                    1. Remove unnecessary containers and blanks from the dashboard.  Somehow there were at least 7 nested horizontal containers, a couple of tiles, and a blank that didn't seem to be serving any purpose in the dashboard I'm working on.  I think Tableau added them without my noticing... So I removed them all, and I think it was the blank that was getting in the way of dragging a new text object into the container.  After the purge, it worked instantly.

                    • If you attempt to remove a container that has something in it, Tableau warns you.  So if I don't get the warning, I delete with impunity.  Hey, there's always the undo button.
                    • In particular, the Tiled containers Tableau adds automatically really seem to mess with putting something on the edge (top/bottom of a vertical, left/right of a horizontal) of a container.  When I remove it, it works so much better.

                     

                    Here's an example:

                    Trying to move Object B to the top of the vertical container I put on an otherwise empty dashboard - but I don't get the option.  My choices are to put it between A & C, or outside of the container.

                     

                     

                     

                    Removed the Tiled container Tableau added to the layout, and I immediately get the behavior I was expecting - to be able to move Object B to the top of the container:

                     

                     

                    2.  Similar to what Shawn Wallwork recommended, I've had luck making both the target container and the object(s) to be added to that container float, putting the object(s) in, then unfloating the container. 

                    3.  Temporarily use a text object or blank object as a placeholder within a container in order to position things just right.  This can work for rearranging objects in a container as well as nesting in an additional container, as Emanual Henry suggested.

                     

                     

                    Jen