5 Replies Latest reply on Oct 18, 2017 4:50 AM by U B Branched to a new discussion.

    Tabcmd

    U B

      Hi all,

      I am trying to execute below script. Previously it has executed successfully. Now it is not working. and gives below error.

      Last week, Tableau Server was upgraded to 10.4 version from 10.3.

      Is this a reason?

       

      SCRIPT :

      tabcmd export "/views/Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://**********.com:80  --png -f "D:\TableauAttachments\Test.png"

       

      ERROR:

      ===== redirecting to http://********.com/vizportal/api/web/v1/auth/signin?path=%2Fviews%2Fviews%2FTest10_4%2FSheet1%3Flanguage%3Den%26authenticity_token%3DoLVLhTV2BHO5vGA3uJjEcWs6Sw5YekL7%26format%3Dpng%26%253Asize%3D800%252C600&siteUrlName=

        *** 302 Found

        • 1. Re: Tabcmd
          Jeff Strauss

          did your security protocol change from http to https or vice versa?

           

           

          Also try without the views.  Such as:

          tabcmd export Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80 --png -f "D:\TableauAttachments\Test.png"

           

           

          If this doesn't work, what does your tabcmd login look like?

          • 2. Re: Tabcmd
            U B

            Hi Jeff,

            There are no any protocol changes. it is always the same protocol (http)

            As you said, I have also tried many versions of tabcmd before. And also tabcmd get command.

            But the same error is given.

             

            Here are some examples of commands that I have executed.

            tabcmd export "/Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80 --png -f "D:\TableauAttachments\Test.png"

            tabcmd export "Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80 --png -f "D:\TableauAttachments\Test.png"

            tabcmd export "/views/Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80 --png -f "D:\TableauAttachments\Test.png"

            tabcmd export "views/Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80 --png -f "D:\TableauAttachments\Test.png"

            tabcmd get "/Test10_4/Sheet1" -f "D:\TableauAttachments\Test.png" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80

            tabcmd get "Test10_4/Sheet1" -f "D:\TableauAttachments\Test.png" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80

            tabcmd get "/views/Test10_4/Sheet1" -f "D:\TableauAttachments\Test.png" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80

            tabcmd get "views/Test10_4/Sheet1" -f "D:\TableauAttachments\Test.png" -U MYUSERNAME -p ******* -S http://xxx.xxx.com:80 

             

            my user is an admin user. it has Server Admin Role.

            • 3. Re: Tabcmd
              Jeff Strauss

              did you download the most current version of tabcmd?  It has to match to the server version 10.4  Tableau Server 10.4 | Tableau Software

              • 4. Re: Tabcmd
                U B

                Hi Jeff,

                Thanks for your help.

                 

                Yes, Tabcmd and Tabadmin versions are the same.

                Version 10400.17.0915.2112

                Tableau Server Version: 10.4.0 (10400.17.0915.2112) 64-bit Windows

                 

                But I solved this error with another way.

                I have installed tabcmd utility on another server. And the same script was executed successfully on the new server.

                Now it is enough for me, I got the solution.

                 

                But i think, firstly Tableau Server should be restart.

                If the error is not resolved, other solutions should be investigate.

                I have informed the Server Admin. He is responsible for installing and upgrading of the Tableau.

                 

                 

                There is also an another error seen on windows event logs.

                 

                 

                The description for Event ID 4096 from source Tableau Server (Filestore) cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

                If the event originated on another computer, the display information had to be saved with the event.

                The following information was included with the event:

                2017-10-18 17:53:06.418 +0300 missingFoldersFetcherScheduler-1   ERROR : com.tableausoftware.tdfs.filestore.jobs.MissingFoldersFetcher - Problem encountered processing missing folders file D:/Program Files/Tableau/Tableau Server/data/tabsvc/dataengine\ToFetchFolderIds\73\da\ToFetchFolderIds6375084778225070395\\\ToFetchFolderIds5041542223798250350.tmp

                • 5. Re: Tabcmd
                  U B

                  Hello all,

                  I have installed tabcmd utility on another machine at yesterday, everything was good and executed successfully.

                  But today same script was not executed on the same machine again.

                   

                  I have analyzed it too much and finally i found the correct solution. It works good. and there is no error while executing tabcmd script.

                   

                  I have scheduled powershell script containing tabcmd. It runs everyday on the same machine.

                   

                  When tabcmd will be executed, it tries to use the previous session which has logged on before.

                  So the script returns "the redirecting error" because the session has destroyed before and it can not find the previous session.

                   

                  After the "tabcmd export" command is executed, the existing session must be ended by executing "tabcmd logout" at the end of the session.

                  So next time new session will be created with "tabcmd export" command.

                   

                  Correct Script:

                  tabcmd export "/views/Test10_4/Sheet1" -U MYUSERNAME -p ******* -S http://mytableauserver.com:80  --png -f "D:\TableauAttachments\Test.png"

                  tabcmd logout

                  1 of 1 people found this helpful