3 Replies Latest reply on Oct 12, 2017 12:48 PM by Caitlin Cooper

    Data Extract Fails with Tableau Data Engine Error 40460

    Chen Zheng

      Hi,

       

      I am refreshing the extracts from a table in Redshift, the volume is ~37 million rows. It works perfectly in Tableau 10.0, but fails in 10.3 and 10.4.

      The error message is:

      Tableau Data Engine Error: 40460: SimpleDatabase::SelectMetadataName: expected found=1, actual found=0 (fk=18446744073709551615 name="Extract" nameTable="SCHEMAS")

       

      I searched and see this link Error "Tableau Data Engine Error: 40460: SimpleDatabase::SelectMetadataName: expected found=1" Appending Data to Extract…

      Since 10.0 works so I guess it's not because of some antivirus issue mentioned in the post.

      To rule out the reason "calculations from the workbook", I tried to create an empty workbook and simply extract data, still I was getting the same error. From the messages shown in the dialog during creating extract, the query to Redshift completed successfully returning all the ~37 million rows, but failed at some last step.

       

      However, when I limited the time range of data and extract ~10 million rows, the extraction succeeded. Could it because of the data size? I don't really think that's too much for Tableau to handle, not to mention Tableau 10.0 does the job just fine.

       

      Could anyone please help me with this issue?

       

      Thanks a lot!