7 Replies Latest reply on Oct 11, 2017 4:01 AM by Simon Runc

    Join problems with10.3 version

    E Hadzic

      Hello all,

       

      In older versions of Tableau, joining two tables was easy. Tableau was able to join on text and numbers (as long as there was the same content).

      Now if it recognises a field as a decimal (even if it are only whole number in it) and in the right table it is a whole number, I can't join them! Quite annoying because, whenever I open an older dashboard, which worked well for quite some time now, this problem pops up...

      It does not even help when converting field in bottom part of the screen.

      So the only possibility is to use the 10.3 newest option: Join Calculation.

      this problem usually ends, after creating the extract, with an error:

      Is there a fix for this? Or am I doing something wrong?

       

      Thank you in advance

      Ed

        • 1. Re: Join problems with10.3 version
          Simon Runc

          hi E,

           

          So you should be able to change the data type in the connect to data screen...click on the little icon indicating the data type and set it to Whole Number, if Tableau has failed to pick up the correct type.

           

           

          Hope that does the trick

          • 2. Re: Join problems with10.3 version
            E Hadzic

            Hi Simon,

            Thank you for very fast reply!

            it does not work unfortunately. That is what I mean by 'It does not even help when converting field in bottom part of the screen.'

            I remember times when this trick did work dough

             

            Ed

            • 3. Re: Join problems with10.3 version
              Simon Runc

              Sorry must have missed that bit!

               

              So what is your data source? and is it that you don't get the option to change the data types, or that even when you make them both the same it still won't let you join them?

              • 4. Re: Join problems with10.3 version
                E Hadzic

                no problem at all, it was not clear, sorry for that:)

                 

                datasource in this case are two tables from SQL server.

                No, it does not work even after changing datatype. It does work dough when using Join Calculation and force it to INT. This is the annoying thing because now I don't trust all other dashboards because all of them have multiple tables in data source.

                It worked before in older versions. I remember in v8 it worked even when it is Text - Number, as long as there is same content.

                • 5. Re: Join problems with10.3 version
                  Simon Runc

                  I'm afraid T8 is too long ago for me to remember! and don't still have that version to test it.

                   

                  I have a MS SQL version of superstore, and in the below image I have changed the Join field [OrderID] to a decimal in one and a string in the other (within SQL they are both INTs)...and it let's me join them (maybe this is because they are both INTs in SQL...so Tableau is, kind of, ignoring my cast!)

                   

                  So in your SQL tables, are the join fields in both tables of data types INTs? and so Tableau is incorrectly re-casting one of these to DECIMALS when it connects? If that's the case I'd raise a support ticket

                  If they are different in the database, an interim solution would be to set them both to INTs in the DB tables (or as you say, use the Calculated field join if that's working)

                  • 6. Re: Join problems with10.3 version
                    E Hadzic

                    Hi Simon,

                    Thanx again for reply and thinking with me!

                     

                    In the db are the fields different, one is INT and other is Float (but with same content).

                    I agree, this kind of things should be right and it is going to be fixed, but for now that is not the issue.

                    The real problem is, it worked in the past, even with text datatype on left and int on right table. That is one thing I found great about Tableau.

                    Now is not working when opened in 10.3 version, so what happens with the dashboards having these kind of joins now? And also, changing datatype as you have suggested above is not helping (always, like in this) too...

                    • 7. Re: Join problems with10.3 version
                      Simon Runc

                      So I wasn't aware the behavior had changed, in 10.3...but then I would never have come across the feature (that joins could be done on different datatypes) as our DB tables are all very consistent (our DBA is a stickler for this kind of thing! and all our Join fields use INTs for performance reasons). As a guess it may have been that when they introduced the Join-on-Calc feature in 10.3, they were forced to ensure non-calc-joins maintained datatype-integrity.

                       

                      As for other models, I'd guess they also would no longer work (I assume you are using Tableau live against the DB and not extracting to TDEs)...but open one up an have a look. If you only have a few, and the DB datatype work isn't due for a while, you might have to go into the joins and set up calcs to cast the fields. If you've got loads of workbooks, getting the DB datatypes fixed (in the DB) might be the best way.