3 Replies Latest reply on Oct 9, 2017 3:53 AM by kbj3030

    Site role showing wrong info

    kbj3030

      Hi All,

       

      We have 3 users with site admin site roles. Later their role changed to Interactor Site role for respective sites.

      Now, If I go and visit the user info at site level. It is showing as Interactor Site role which is correct but when I check the users at server level their role is shown as Site Admins still.

      May I know how can I resolve this issue? Below are the details for your ref

       

      Tableau Sever Version: 9.2.0

      Mode of Auth: AD

       

      Let me know if you require any additional info from my side.

        • 1. Re: Site role showing wrong info
          Jeff Strauss

          It's either a bug that has been fixed in later releases, or there's a problem with the search index.  Try on the server level to rebuild the search index and see if this helps.

           

          • 2. Re: Site role showing wrong info
            Brandon Babbitt

            Trinadha K This sounds like expected behavior.  It is possible for a user to be assigned as a Site Administrator for some sites, but not for other sites.  User roles are set at a site level basis.  In Tableau Server 9.2, If you select the individual user and go to the "Site Membership" options for that user, you should see a dropdown for "All Sites" or "Assigned Sites."  You will need to verify that the user is set to the appropriate Site role for each site.

             

            Here is a screenshot of a reproduction of the scenario you have described.  Make sure to assign the user to the correct Site role for the sites they should be assigned:

             

            testuser123.png

            2 of 2 people found this helpful
            • 3. Re: Site role showing wrong info
              kbj3030

              Hi Jeff,

               

              I will give a try on this and update you. Thanks!