5 Replies Latest reply on Oct 11, 2018 2:13 PM by Raj Garimilla

    Installing Tableau SDK with Anaconda (with python 3.6)

    Vishruth Reddy

      Hi People,

       

      This question slightly requires knowledge of working with Anaconda. Please let me know if you've worked on it as i'm completely new to it.

       

      I have Anaconda (with python 3.6) installed on my ubuntu machine. However, i've created a separate environment for Tableau SDK, say env_tableau_sdk within Anaconda which runs on Python 2.7.

       

      1. I've downloaded the 64-bit python version of Tableau SDK and then extracted it in a particular location.
      2. Fired up the terminal, changed the directory to where i extracted the Tableau SDK files and ran the comand 'sudo python setup.py install'
      3. It just gave some extraction messages and i did not happen to see any error messages.
      4. Later fired up anaconda, run the environment created for Tableau SDK which runs on Python 2.7
      5. Now just to test out whether the installation was successful or not, i've tried the import statement 'from tableausdk import *'

       

      From any random directory i get the following error

      Traceback (most recent call last):

        File "<stdin>", line 1, in <module>

      ImportError: No module named tableausdk

       

      Now i use the os.chdir() to change my working directory to the directory where Tableau SDK was extracted, i get the following error

      Traceback (most recent call last):

        File "<stdin>", line 1, in <module>

        File "tableausdk/__init__.py", line 14, in <module>

          from .Types import *

        File "tableausdk/Types.py", line 17, in <module>

          common_lib = libs.load_lib('Common')

        File "tableausdk/Libs.py", line 36, in load_lib

          self.libs[lib_name] = ctypes.cdll.LoadLibrary(self.lib_paths[lib_name])

        File "/home/vishruth/anaconda3/envs/TableauSDK/lib/python2.7/ctypes/__init__.py", line 440, in LoadLibrary

          return self._dlltype(name)

        File "/home/vishruth/anaconda3/envs/TableauSDK/lib/python2.7/ctypes/__init__.py", line 362, in __init__

          self._handle = _dlopen(self._name, mode)

      OSError: libpcre16.so.0: cannot open shared object file: No such file or directory

       

      I'm just trying to reach out if anyone has face this issue or if someone could help me with this.

       

      Thanks,

      Vishruth