4 Replies Latest reply on Jun 15, 2017 9:47 AM by Matt Coles

    Error on Simple alert Maximum rows of 10000 exceeded.

    Judith Lanzo

      I recently received an error message of an Alert a user subscribed to (Needless to say I think the user should've user a regular subscription and didn't quite understand the VizAlert process).  However the issue intrigued me.

       

      There error message stated:

      General errors:
      Maximum rows of 10000 exceeded.

       

      As an FYI we are on Tableau server 10.1.5 and using VizAlert 2.0.

       

      In reviewing the documentation I see a calculated field/parameter called default_data_maxrows with in the ScheduledTriggerView Viz.  The default is set to 10000.  Since this is the only place I see a limit of 10000, I assume this is related.  However what I don't understand is the description in the documentation: The maximum number of alerts that can be sent at once.

       

      I thought that it might have to do with the number or rows returned in the data, however there is <2000 rows in the returned data set. There are a total of 11 subscriptions to this same alert schedule, 1 which is an Advanced Alert.  The rest all seemed to execute fine.  So I don't see how it would be exceeding the maximum number of alerts that can be sent at once.  Unless I am misinterpreting what this means.

       

      I don't see anything that stands out in the logs, but I can send them if you wish.

      I noticed in the temp directory the csv for this exists, but not the png (as it does for similar subscriptions).

      the only other thing I noticed on the alert subscription, is the do not send if data is empty is checked. However, I just subscribed to the same view, without checking the data is empty field and received the same error message.

       

      Any Insights?

        • 1. Re: Error on Simple alert Maximum rows of 10000 exceeded.
          Matt Coles

          Hey Judith, from the config workbook (v2.0.1), here's the description of the default_data_maxrows:

           

          System wide default for the maximum number of rows that VizAlerts will attempt to process from any VizAlert, when the viz data is downloaded.

           

          For more information, or to override this setting dynamically, see the viz_data_maxrows calculation.

           

           

          The description of the viz_data_maxrows field, which can be edited to override the default value for certain alerts / people / projects, is:

           

           

          The maximum number of rows that VizAlerts will attempt to process from any VizAlert, when the viz data is downloaded. This applies to both Simple and Advanced alerts.

           

          The rationale in having this option is that an alert author may inadvertantly leave a filter off, resulting in a massive amount of data that could cause:

           

          -Large attachment sizes

          -Large email volumes sent to many people who shouldn't be receiving them

          -General Tableau Server resource drain

           

           

          In the code, the intent is that once the CSV data for the trigger viz for your alert has been downloaded, we count the rows in it, and if they exceed the viz_data_maxrows value, we halt processing. So in your case, I would expect to find a CSV with > 10,000 rows in there. The "Do not send if data is empty" being checked should not matter at all.

           

          Are you certain that none of the CSVs in your temp folder have more than 10,000 rows?

          • 2. Re: Error on Simple alert Maximum rows of 10000 exceeded.
            Judith Lanzo

            I looked deeper and opened the csv file in the temp directory.  Apparently, the csv output is >11,000.   The csv is creating a row for each measure, which was not what I was expecting.  I'm guessing that is due to how the extract creates the columnar data.  So in conclusion, I guess the attribute default_data_maxrows is intended to be the maximum number of rows in the csv output not the maximum number of alerts that can be set at once.

             

            Are there any general guidelines in setting this number?  I can obviously change the default, but I assume there was some reasoning why 10000 was chosen.

            • 3. Re: Error on Simple alert Maximum rows of 10000 exceeded.
              Judith Lanzo

              Matt,

               

              I just updated with a reply before I saw your note.  I was looking at the data from a database row count perspective, but then saw when I opened the csv it was generating more rows than expected as the measures were being represented as rows vs. columns.

               

              So yes your explanation makes sense and confirms the intent of the field.  I was looking at the description of the field in the Install Guide Documentation vs. the actual twb.  I see now what is in the twb is different than what is in the install guide doc.

               

              Thanks for your response.

              • 4. Re: Error on Simple alert Maximum rows of 10000 exceeded.
                Matt Coles

                Ah, I see what you mean. Yes, we should update the wording in the Install Guide, it's really not accurate.

                 

                As far as guidance on that setting goes, just stick with the default until someone hits it. I bumped it up quite a while ago from 1,000 to 10,000 because I hit too many situations where alerts really did need 1,000 rows. 10k seems the appropriate level to stop and ask "wait, why do you have so much data in your viz?". If there's a legitimate reason, then you can always make an exception for that viz, that author, or whatever, by editing the viz_data_maxrows calculation.