2 Replies Latest reply on Jul 4, 2018 8:31 AM by Hiep Nguyen

    Logshark Publishing error

    Arun Yadav

      Hi All,

       

      I'm facing issue while setting up Logshark to get the workbook published on server. REST API is enabled on server , by default. Below is the error message.

       

      2017-05-09 11:57:30,433 tabmonmachine_17050918384704_e3logs0508zip [1] INFO Logshark.Controller.Workbook.WorkbookPublisher - Publishing 1 workbook to Tableau Server..

      2017-05-09 11:57:31,933 tabmonmachine_17050918384704_e3logs0508zip [1] INFO Logshark.Controller.Workbook.WorkbookPublisher - Publishing workbook 'Apache.twb' to https://mytableauserver.com/#/projects/426/workbooks:443/..

      2017-05-09 11:59:34,121 tabmonmachine_17050918384704_e3logs0508zip [1] WARN Logshark.Controller.Workbook.WorkbookPublisher - Workbook publishing attempt #1 failed.  Retrying in 5 seconds..

      2017-05-09 12:01:38,245 tabmonmachine_17050918384704_e3logs0508zip [1] WARN Logshark.Controller.Workbook.WorkbookPublisher - Workbook publishing attempt #2 failed.  Retrying in 5 seconds..

      2017-05-09 12:03:43,499 tabmonmachine_17050918384704_e3logs0508zip [1] ERROR Logshark.Controller.Workbook.WorkbookPublisher - Publishing of workbook 'Apache.twb' failed: Failed to publish workbook 'Apache.twb': Failed to retrieve successful response for POST request to 'https://mytableauserver/api/2.2/sites/407ad167-bf62-4704-b8cc-69239cc49e12/workbooks?overwrite=True' after 3 attempts: The remote server returned an error: (400) Bad Request. [3 attempts made]

      2017-05-09 12:03:43,507 tabmonmachine_17050918384704_e3logs0508zip [1] INFO Logshark.Controller.Workbook.WorkbookPublisher - Successfully published 0 workbooks! [1 failure]

      - Apache.twb: Failed to publish!

      2017-05-09 12:03:43,508 tabmonmachine_17050918384704_e3logs0508zip [1] ERROR Logshark.Controller.Plugin.PluginExecutor - Failed to publish workbooks: The following workbooks failed to publish: Apache.twb

      2017-05-09 12:03:43,530 tabmonmachine_17050918384704_e3logs0508zip [1] DEBUG Logshark.Controller.Plugin.PluginExecutor - Logshark.Exceptions.PublishingException: The following workbooks failed to publish: Apache.twb

         at Logshark.Controller.Workbook.WorkbookPublisher.PublishWorkbooks(IPluginResponse pluginResponse)

         at Logshark.Controller.Plugin.PluginExecutor.ExecutePlugin(Type pluginType)

      2017-05-09 12:03:43,532 tabmonmachine_17050918384704_e3logs0508zip [1] ERROR Logshark.Controller.Plugin.PluginExecutor - Apache failed to execute successfully.

       

      Can someone please help me in fixing it ?

       

      Regards,

      Arun

        • 1. Re: Logshark Publishing error
          Mary Thoen

          Hi Arun,

           

          I ran into the same issue.  It turns out there is a defect when using localhost. Justin was able to figure out a workaround until it gets corrected.

          In my logshark.config file, I needed to change localhost to my actual machine name under PostgresConnection.

          In the Postgres pg_hba.conf file, I needed to add two host records to allow IPV4 and IPV6 connections as described in #5 under Install and Configure PostgreSQL in the Logshark docs: Install and Configure PostgreSQL .

          After modifying the pg_hba.conf file, I needed to restart the PostgreSQL service under Services on my machine.

           

          Similar to running Logshark from a different machine than where the PostgreSQL db is installed.

           

          Mary

          • 2. Re: Logshark Publishing error
            Hiep Nguyen

            Hi Mary,

             

            I recently trying to setup Logshark.  I have debugged to the point I am now having the same issue as Arun.  I have tried Justin suggestion to use the actual machine name in the PostgresConnection under the logshark.config file.  I have also added the IPV4 host records in the Postgres pg_hba_conf file.  My question is which Postgres instance are you and Justin referring to?

            My current setup has Logshark using its own Postgres server installed on one machine.  While the Tableau server and its Postgres server are on another machine.  Which Postgres instances does Logshark need remote access into?  I thought publishing the workbook is going through the Tableau server and does not communicate with Tableau Postgres directly.

            This last publishing piece is the only piece that is not working with my Logshark setup.

            Any suggestions would be appreciated.

            Thanks in advance.

             

            Hiep

             

            Update: Logshark was able to log in and create the Project under the Site.  However, it was not able to publish the workbook.

            Update: Found my own answer after I helped a client with their issue.  It clicked.  Since the Workbook has the Logshark Postgres database sent along when publishing, the Logshark Postgres has to have the hostname/IP of the Tableau server for it to have read access remotely.

             

            Issued answered.