3 Replies Latest reply on Mar 28, 2017 3:58 PM by Shinichiro Murakami

    Is there a setting that disables "Show Empty Rows/Columns"?

    Brian Goddard

      This is a question for Tableau version 10.1 connected to .xlsx file(s).

       

      I'm trying to build a table to show an individual student's tardies per period per day.  Because I'm filtering to a single student, the table is only showing a day of the week if there is some kind attendance data for that student for that day (i.e. for Tuesday to be on the table, the student needs to have been absent or tardy on at least one Tuesday).  However, I want the table to show all days regardless of whether or not there is data and to leave those columns blank.  All the reading I've done has suggested that I need to go into Analysis>Table Layout>Show Empty Columns.  However, I'm unable to select that option (it's greyed out). 

       

      I tried to figure out if there was a work around, but when I made a workbook without any of the students' personable identifiable data to ask for help, the option was there again.  I'm not sure why I can't enable "Show Empty Columns"; is the option unavailable because I'm using cross data source filtering for example?  I'm not sure why that should matter, but it's the only salient difference I can see between the dummy chart and the chart I made originally.  If so, is there another way to get the functionality I need?  I'm attaching some screenshots (I know that packaged workbooks are usually best, but the packaged workbook I made didn't have this issue and I can't share the full document per FERPA).  If you think that the packaged workbook could help for a work around, I can attach it.  However, if there is a way to enable "Show Empty Rows/Columns" that would be much easier.