8 Replies Latest reply on Jan 18, 2017 10:06 AM by Tom W

    ODBC issues

    Knox Hutchinson

      Good evening all!

       

      I am working on getting an ODBC driver working to connect to our phone system, TASKE. It appears that I can connect to the database just fine as I can quickly see a list of all of the tables, but I am receiving this error after connecting to the database and trying to drag a table to the data preview window:

       

      • The connection to the data source might have been lost.
      • ExternalProtocol::PipeMessageSource::ReadBytes: Communication with the Tableau Protocol Server process was lost.

       

       

      When I try to use a custom SQL query (select top 1000 [agents].[ID] from [agents]), I get

       

      • [TASKE ODBC Driver]Expected lexical element not found: <identifier>

       

       

      I can connect to the database and pull in data just fine using Microsoft Access. I've checked the log files but I'm honestly not sure what I am looking for. I've even tried importing the data as linked tables in Access, and then connecting to that but I still get an error. Any help is appreciated!