5 Replies Latest reply on Jan 12, 2017 3:17 PM by Russell Christopher

    tabcmd get "http://localhost/#/datasources.xml" returns empty document

    Marc Alexander

      At a previous company, we used a script to query our datasources on Tableau Online.  I'm trying to modify the code to work with our onsite Tableau Server 10.1 installs.  I struggled with the syntax for a bit, but got over that hurdle.  Now I can connect and pull down the datasources.xml document but the file it produces does not have any real content. 

       

      This is what I'm getting:

      <!DOCTYPE html>

      <html xmlns:ng="" xmlns:tb="">

        <head>

        <meta charset="UTF-8">

        <meta http-equiv="X-UA-Compatible" content="IE=edge">

        <meta name="viewport" content="width=1024, maximum-scale=1.3">

        <meta name="apple-itunes-app" content="app-id=434633927">

        <meta name="format-detection" content="telephone=no">

        <script>var BuildId = 'cmzczz8dcedy841ggioi27qfr'; var StaticAssetsUrlPrefix = '';</script>

        <link rel="stylesheet" type="text/css" href="vizportal.css?cmzczz8dcedy841ggioi27qfr">

        <script src="/javascripts/api/tableau-2.1.1.min.js?cmzczz8dcedy841ggioi27qfr"/>

        <script src="vizportalMinLibs.js?cmzczz8dcedy841ggioi27qfr"/>

        <script src="vizportal.min.js?cmzczz8dcedy841ggioi27qfr"/>

        </head>

        <body class="tb-body">

        <div ng-app="VizPortalRun" id="ng-app" tb-window-resize class="tb-app">

        <div ui-view="" class="tb-app-inner"/>

        <tb:react-toaster/>

        <script type="text/ng-template" id="inline_stackedElement.html">

        <div tb-window-resize tb-left="left" tb-top="top" tb-right="right" tb-bottom="bottom" tb-visible="visible" class="tb-absolute"/>

        </script>

        <tb:stacked-elements/>

        <tb:component-stacker/>

        </div>

        </body>

        </html>

       

      Any ideas on what I'm doing wrong?

       

      To eliminate variables, I'm just using a very basic .bat file for testing.  I'm running it on the server.

       

      Many thanks for your help,

       

      Marc