3 Replies Latest reply on Jun 22, 2018 12:50 PM by Allen Gradnigo

    Join table: date type mismatch

    noterrain.wu

      I have two tables from different data source, one is from BigQuery, the other is a static CSV file. But when I perform join in tableau it says "Type mismatch between [sourceA].[date](String) and [sourceB].[date] (Date). Though I've already configure both data type as a date in Tableau:

       

       

      Error message:

      Screen Shot 2017-01-03 at 4.37.36 PM.png

      SourceA's date is a string so I configure it into date :

      Screen Shot 2017-01-03 at 4.32.48 PM.png

      SourceB have date object by default.

      Screen Shot 2017-01-03 at 4.32.42 PM.png

      Does anyone know what cause this and where the solution is?

        • 1. Re: Join table: date type mismatch
          Mahfooj Khan

          Hi,

          I guess you've to change the data type at data source (Source A) level. Once done then connect to tableau.

           

          Mahfooj

          • 2. Re: Join table: date type mismatch
            Bjorn Andersson

            I have a very similar issue in v.10. Joining an Oracle source with an Excel source. Both dates are dates yet Tableau insists one is datetime and will not allow the join. In my case changing the Excel date to datetime in the Tableau interface resolved the issue.

             

            joinIssue.jpg

            • 3. Re: Join table: date type mismatch
              Allen Gradnigo

              I had a similar issue. This is how I solved it today:

               

              Right click one of the data sources.

              Click Edit Data Source...

              Pull in the second data source to initiate the join.

              Click the Inner Join icon.

              If Tableau correctly recognizes your left data field, choose it.

              On the right side, click the dropdown box.

              At the bottom, there should be an option titled Create Join Calculation...

              In my case, I typed DATETIME([Data_Field_Name]) because I was having issues with dates. You'll want to use the format you need.

              The red exclamation error icon should go away.

               

              Let me know if you experience similar results.