14 Replies Latest reply on Dec 30, 2016 5:58 AM by Yuriy Fal

    Red Pill on Upgraded 10.1 Workbook?

    John Sobczak

      Does anyone know what the red pill in the below image means?   It happened to my workbook after I upgraded to 10.1 from 9.2.  I have included the 9.2 as well as the 10.1 image of it. There is no error message itself on the pill and everything seems to be intact with the view.

       

      Tableau 10.1 Red Pill (multiple fields pill).png

       

      Tableau 9.2 Before Screen Shot of Multiple Fields Pill.png

        • 1. Re: Red Pill on Upgraded 10.1 Workbook?
          Jim Dehner

          Good morning - the red pill usually means that the field is broken in some way - look at Measures under Data and see if any on the measures have a red !  - that would give you a path to see what is broken

           

          Jim

          • 2. Re: Red Pill on Upgraded 10.1 Workbook?
            Michelle Kosmicki

            What Jim said and....

             

            Also check any calculations you have in the workbook.

             

            If you created groups, you may need to update the groups. I'm not sure why, but groups don't seem to upgrade like everything else.

             

            What is interesting is that it is the "shapes" pill that turned red, so I'm guessing you have a group or calculation that is used to assign shapes somewhere.@

            • 3. Re: Red Pill on Upgraded 10.1 Workbook?
              John Sobczak

              I realize red means broken but everything seems to be in order.  I don't have any red ! marks in my measures pane and furthermore all the pills on the individual layer marks cards are all green or blue not red.  So not sure why this multiple fields on my "All" marks card layer is red.

              • 4. Re: Red Pill on Upgraded 10.1 Workbook?
                Joe Oppelt

                The red pill plunges you into the real world. 

                 

                The first thing I would try is to look at all the individual MARKS layers.  But you said you did that already.  (And the sheet works, even with the red pill in there?)

                 

                The next thing I would try is "Duplicate Sheet".  Does the red pill go away on the copy?

                 

                If not, the next thing I would try is to delete individual measures from the rows/columns shelf.  One at a time.  Hit back-arrow after each one to put it back on.  Or combos of deletions.  Or delete them all and then back-arrow to put them back on...

                 

                Just some ideas.  Those are things I would try.

                 

                You might have a bug to report once you get this thing sorted out.


                BTW, if you want me to try it for you, I could take your 9.2 workbook and upgrade it to 9.3.  And then to 10.0.  And then to 10.1.  I have all the intervening desktop versions available to me.  Let me know if you want that.  It might be interesting to see what happens.

                • 5. Re: Red Pill on Upgraded 10.1 Workbook?
                  John Sobczak

                  Thanks Joe those are great thoughts.  I tried all of those things and still the red persists on the multiple fields pill.  What is even funnier is that only 2 of the 4 marks layers are using shapes and when I remove shapes from one of those 2 layers the shapes multiple fields pill persists.  Even when I remove all of them and just add one back in I get the multiple fields (red) pill on the "All" marks card.  Very strange.  I also looked at the describe sheets detail and nothing stands out there.

                  • 6. Re: Red Pill on Upgraded 10.1 Workbook?
                    Christina Davis

                    This is a long shot but have you tried re-selecting the shapes? Maybe there is a particular shape that your pill is using that changed between the two versions.

                    • 7. Re: Red Pill on Upgraded 10.1 Workbook?
                      John Sobczak

                      Christina, That's another good thought that I just tried but it still doesn't resolve it.  When I force the other multiple field pills to go red they give me a tooltip stating invalid and along with marks card layer.  I get no tooltip for the seemingly corrupt one.

                       

                      btw speaking of tooltips I really was delighted about the quick filter tooltip showing which sheets they are applied.  That wasn't something I ever saw advertised

                      • 8. Re: Red Pill on Upgraded 10.1 Workbook?
                        Michelle Kosmicki

                        You've got a tough red pill!

                         

                        What about parameters, sets, and actions?

                         

                        In workbooks I've inherited from others I've often had to unhide them (not sure why they were hidden) to see what is going on. I've actually had a few that were the problem.

                        • 9. Re: Red Pill on Upgraded 10.1 Workbook?
                          Yuriy Fal

                          Hi John,

                           

                          I've noticed the same behaviour recently,

                          it may be specific to the exact (10.1.x) version.

                          Which one do you have installed?

                          And what is the primary datasource

                          of the view in question?

                           

                          Yours,

                          Yuri

                           

                          PS No harm so far from those Red Pills :-)

                          • 10. Re: Red Pill on Upgraded 10.1 Workbook?
                            Jonathan Drummey

                            Hi John,

                             

                            If you've upgraded and haven't changed anything in the workbook and something is broken then I suggest you submit this to Tableau support. The Tableau devs really want to avoid breaking workbooks on upgrades.

                             

                            Jonathan

                            • 11. Re: Red Pill on Upgraded 10.1 Workbook?
                              John Sobczak

                              Yuri,

                               

                              It was 10.1.1 but I just downloaded 10.1.3 as I see it was released yesterday.  I still get the same result.  The data source is a published data source on Tableau server (from MS SQL Server).  I will take Jonathan's advice, although it really isn't causing me any issue other than the color is wrong.

                              • 12. Re: Red Pill on Upgraded 10.1 Workbook?
                                Yuriy Fal

                                Hi John,

                                 

                                The mysterious Red Pill is evident

                                when you're opening a view inside

                                a 9.x workbook in 10.x version of TD.

                                 

                                Besides, the view should be constructed

                                to contain at least the following objects:

                                 

                                1. Two+ Green Pills (having their own Mark Shelves)

                                with at least one Mark Shelf as either Line or Shape --

                                so either Path or Shape control is active for at least one Pill.

                                 

                                2. The Pills on either Path or Shape should be different

                                on each Mark shelf, better to have one of the shelves

                                a different Mark type (Bar, Area, Circle etc).

                                 

                                3. Opening such 9.x view in 10.x TD triggers Red Pill on All shelf.

                                 

                                Please find the attached sample v9.3 workbook as an example.

                                 

                                Yours,

                                Yuri

                                1 of 1 people found this helpful
                                • 13. Re: Red Pill on Upgraded 10.1 Workbook?
                                  John Sobczak

                                  Thanks Yuri for researching this!  I think I follow as I have something similar to your workbook with 4 mark shelves two of which have nothing on LOD card.

                                   

                                  This is interesting and I'm sure will get more attention as workbooks with these conditions start migrating to 10.

                                  • 14. Re: Red Pill on Upgraded 10.1 Workbook?
                                    Yuriy Fal

                                    John, you're welcome.

                                     

                                    Please let me know if you'd find something.

                                     

                                    Yours,

                                    Yuri