2 Replies Latest reply on Dec 6, 2016 12:05 PM by Zhennan Liu

    Can't publish datasource after upgrading to server 2.3

    Zhennan Liu

      We have a python script which is building a tdsx file and publishing it to the server. The script has been running great on 2.2. But it got broken somehow after we upgraded to 2.3 (please see below for errors). We did not change the body request after we upgraded. Don't understand why this error happened.

       

      I downloaded the python API sample for server 2.3 and can run it to publish a workbook to server 2.3. However, when I modify it to publish a datasource, it throws out the same error:

       

      <?xml version="1.0" encoding="UTF-8"?> <tsResponse xmlns="http://tableau.com/api" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://tableau.com/api http://tableau.com/api/ts-api-2.3.xsd"> <error code="400011"> <summary>Bad Request</summary> <detail>There was a problem publishing the file \'datasource.tdsx\'.</detail> </error> </tsResponse>

       

       

      Any thoughts or suggestions would be appreciated!

       

      Thanks!