5 Replies Latest reply on Nov 1, 2016 6:15 AM by Yuriy Fal

    Loading fixed width file - ignore field separator in file properties

    Elena Semenova

      Hi All!

       

      I'm using schema.ini file to load fixed width file. Some fields in .TXT file contains characters specified as possible field separators in the  file properties in Tableau.

       

      I can't make Tableau to ignore that. It automatically parse the txt file using field separator ('space' in particular) ignoring Format settings in scema.ini.    How to work around that?

       

      file sample:

       

      scema.ini sample:

       

      [file.txt]

      ColNameHeader=True

      Format=FixedLength

      TextacterSet=ANSI

      DateTimeFormat=YYYYMMDD

      DecimalSymbol=.

      MaxScanRows=0

      col1=Field1 Text Width 1

      col2=Field2 Text Width 10

      col3=Field3 Text Width 2

      col4=Field4 Text Width 23

      col5=Field5 Text Width 1

      col6=Field6 Text Width 8

      col7=Field7 Text Width 2

      col8=Field8 Text Width 2

      col9=Field9 Text Width 8

      ......

       

       

      Load result: