1 Reply Latest reply on Oct 27, 2016 2:39 PM by Jeff Strauss

    Tableau data extract command line -utility not working

    Semanti Mandal

      Hi,

       

      We are using the Tableau data extract command line utility to refresh the extracts. We have been successful in refreshing our datasources  in UAT environment but running the same process on our production environment is giving us issues.  Using tableau v9.3 Some of the issues that I have noticed along the process are-

       

      First of all it always shows error if the project/workbook or the datasource names have "hypen" or a space in between them . Suppose a datasource named "Business users- Sales" . It doesn't recognize the data source name. I tried removing spaces and it gives me the same error as datsource can't be found.

      I did a testing using a datasource which doesn't have hyphen /spaces and it works but then it gives me an error on the source-username /source-password as "Microsoft SQL Server Native Client --login failed for user -invalid username and password.

      I logged in to the sql server database using my network credentials and everything looks fine.

       

      Here is the command I am using--

       

      tableau refreshextract --server https://tableauuat.server.com --site sales --username sema --password "password" --project " Analytics" --datasource " Industry" --source-username sema --source-password "password"

      Am I doing something wrong?

       

      Any suggestions would be helpful.