1 Reply Latest reply on Oct 12, 2016 12:32 AM by lei.chen.0

    Server permissions needed?

    Andy Holt

      Hi there

       

      I have a batch file set up to run tabadmin backup.

      When I run the file manually it runs fine, does what it is meant to and creates the tsbak file where I specified.

      One weird thing though, is that I get a User Account Control prompt up (even when running it as Administrator) asking me whether I "want to allow the following program to make changes to this computer?"

      All good so far (sort of?).

       

      However when I set a task in Task Scheduler and run the task to test it in there it just hangs.

      I figure it must be something to do with the permissions and rights set on the server (no modify access or something?) but I am no server administrator and don't know how or what I need to change.

       

      We have a systems administrator here, but he has no experience with Tableau Server and just told me to set the task to run under our 'Administrator' account (which even with my limited knowledge seems less than 'ideal').

      That still doesn't work and still hangs.

       

      Does anyone at all have a clue what I should tell my admin guy in terms of what I need?

       

      I found these guides regaridng the Run As User Account, but they are beyond me, to be honest:
      http://onlinehelp.tableau.com/current/server/en-us/help.htm#runas_confirm.htm

      Create and Update the Run As User Account

      Any help, most gratefully received.

      In my previous role I had two accounts set up for me, one as a Tableau Server service account and one as an account for running and scheduling scripts. That's what I was used to.

      It's tricky coming into a new company with no documentation trying to unravel a ball of tangled wool!

       

      Thanks loads

       

      Andy