4 Replies Latest reply on Oct 3, 2016 10:28 PM by Rishabh Dhingra

    Connection to Oracle - Data Issues

    Rishabh Dhingra

      Hi,

       

      I am facing a weird issue with my connection to Oracle. I have connected to a table in Oracle from Tableau Desktop and it returns no data, whereas there is data in oracle table. This doesn't happen with all the tables, I am getting data for a couple of other tables I tried whereas for some tables no data row is returned.

       

      As shown below, there are data rows in Oracle table (Invoice table), there are 6611 records in this table:

       

      Oracle Count.JPG

       

      and this is my connection to the same table from Tableau, and doesn't return any data.

       

      Tableau Data.JPG

       

      As I mentioned, it is not like that I am not getting data for any table. I connected to couple of other tables from Tableau and it returns the data, example:- orders headers table

       

      Oracle

       

      Oracle Headers Count.JPG

       

      Tableau

       

      Tableau Headers Data.JPG

       

      I am not sure what is going on and why I am seeing this behavior. I am guessing that I might be missing something. Could anyone suggest?

       

      Thanks,

      Rishabh

        • 1. Re: Connection to Oracle - Data Issues
          Siraj Alimohamed

          Hi Rishabh,

           

          My first thoughts were on security. Can you confirm that the tables that you refer above have the same security settings?

           

          Cheers!

          • 2. Re: Connection to Oracle - Data Issues
            Rishabh Dhingra

            Hi Siraj,

             

            I had the same thought initially, so I checked the security settings which are same.

             

            I tried connecting to the same table (Invoice) through Qliksense and it works fine with Qliksense. However, with Qliksense I am unable to see orders header table which I am seeing with Tableau.

             

            Strange things happening!!!!

            • 3. Re: Connection to Oracle - Data Issues
              Siraj Alimohamed

              Have you checked the logs on Tableau Desktop to see what queries are being fired to Oracle? Maybe it might be worth trying to run the same queries outside Tableau to see if you can separate out the issues.

               

              Another approach would be to write a Custom SQL with just one column to see if that brings data for the invoice table on Tableau. If it does, I wonder if there's any unsupported data type that is causing an issue.

               

              Let me know what you find..

              • 4. Re: Connection to Oracle - Data Issues
                Rishabh Dhingra

                Hi Siraj,

                 

                I have already tried using Custom SQL but still I am not getting any records. Initially, I was joining order table and invoice table based on order number to get both order details and invoice details. That is when I realized there seems to be some issue with  Invoice data as it was returning Null (using Custom SQL). I ran the same query in toad for oracle and it was running fine.

                 

                I just had a look at the logs and picked up the query , which is just a simple select query on invoice table and it is running fine outside tableau.

                 

                I guess it would be worth contacting Tableau support.