3 Replies Latest reply on Sep 26, 2016 11:09 PM by eva fang

    Can't change to use AD after Server Uninstallation without backup

    eva fang

      Hi,

      I followed the instructions from this page (Modifying Tableau Server Authentication Method | Tableau Software ) to uninstall Tableau Server 10 as I wanted to switch to use AD. I didn't need to backup and previous data, so I skipped the backing-up steps. I did follow step 5 and 6 to delete PrgoramData etc. folders. However, after re-install Tableau Server 10, before server setup, a error message popped up (see attached screenshot) and it didn't go through the server setup process. I can manually go to /bin directory to start server setup and window but I still could not change to use AD - those fields were still greyed out at server setup window.

       

      I have tried uninstall and reinstall twice with system reboot in between. I still get the same result.

      What should I do now? Thanks in advance for your help.

       

      P.S. the server version I uninstalled was TableauServer-64bit-10-0-0 and the version I re-installed was TableauServer-64bit-10-0-1.

      er.PNG

       

      Message was edited by: eva fang

        • 1. Re: Can't change to use AD after Server Uninstallation without backup
          eva fang

          I just tried to uninstall again from Control Panel, this error msg popped up 3 times. I clicked YES to proceed the uninstallation, and i'm wondering if it's normal.

          uninstall.PNG

          • 2. Re: Can't change to use AD after Server Uninstallation without backup
            Russell Christopher

            Hi Eva -

             

            Not exactly sure what happened to get you into this mess, but sorry! Once a base config has been laid down in \programdata\, you need to delete it AGAIN, else your authentication options won't be enabled. It sounds like somehow the licensing problem allowed setup to complete with a default (Local Security, not AD) config. Once it's there, you must start again

             

            At this point, here's what I'd try. Make 100% sure that you follow all of these steps "As an Admin" - In other words, Run Server Setup with the "Run as Administrator" permission set, etc. I also wonder if you already have a FlexNet licensing app (what your error is complaining about) installed. If this were my server, I'd try this:

             

            • Manually stop the Tableau Server Application & Tableau Server License Manager using servces.msc
            • Uninstall. Ignore error messages, as your current setup seems well and truly hosed. Don' delete anything else yet
            • Restart the machine and get into services.msc again to make sure the services above are gone. If not, you can remove them with sc delete <servicename> (found under "Service Name" on the General tab of the service. It's pretty rare I've every had to do this and I am constantly setting up machines at work.
            • Now that all services are stopped "for sure", delete \programdata\Tableau and the anything under the Tableau Server folder back in \Program Files
            • Bounce the server again (100% overkill, but whatever) and install.
            • 3. Re: Can't change to use AD after Server Uninstallation without backup
              eva fang

              Hi Russell,

              Many thanks for taking the time and responding to my query. Your local Tableau team has opened a support ticket for me o this issue. I have provided more details based on their instruction. Case# 02385887