1 Reply Latest reply on Sep 21, 2016 2:50 AM by Russell Christopher

    Tabjolt | User credential not picked from userpool.csv

    Kunal Kumar

      Hi,

      I am trying to load test few dashboard with concurrency of 20-30 users. But when I am trying to run tabjolt by specifying a test admin user in userpool.csv even then its picking the user through which I logged into the injector machine(from where I am running tabjolt) to run the load test and not the user mentioned in userpool.csv.

       

      To perform this activity I have created an admin user so that I could capture the tableau server performance info as well.

      I added the credential of this user to my userpool.csv file as below:

      UserName,Password,Role

      testuser,******,ServerAdmin

       

      Sample from my vizpool.csv file:

      /site/XYZ/views/DummyDashboard/DummyDashboard?:refresh&:iid=1

       

      In perfTestConfig.yaml file, I have below setting for force login and file name for user detail:

      forceLogin: true

      loginUsersCsvFileName: userpool.csv

       

      Please Note:

      We have single sign on capability enabled on server but to run the load test via tabjolt we are disabling the single sign on.

       

      Could you please help me where I am going wrong.

       

       

      Thanks

      Kunal

        • 1. Re: Tabjolt | User credential not picked from userpool.csv
          Russell Christopher

          Hi Kunal -

           

          How are you determining that the wrong user is being used to execute the viz?

           

          Please explain what SSO mechanism you were using, and exactly how you turned it off.

           

          To begin with, get rid of the &:iid=1 on your vizpool string. By leaving it on you are forcing Tableau to use a specific vizql session. I see you are also using :refresh - this forces Tableau Server to requery the datasource each time the viz is executed, which it generally doesn't do in the real world. In the real world, the Server will rely on cache when it can...So unless you have a specific reason why you want to hit the database each time a viz renders, you should remove this string as well.