4 Replies Latest reply on Dec 9, 2016 10:25 AM by Andy Piper

    Tableau 9.3.6 Mapbox blank map

    Aaron Eisenbarth

      Hello all,

       

      I am working with the Mapbox API which works wonderfully on desktop (9.3.6), but the moment that I upload to Server (9.3.5) the background map simply disappears.

       

      Desktop

      Server

       

      I cannot share the workbook although I assure you that the same settings were used on the previous worksheet in the workbook and that particular map works both on server and desktop.

       

      Are there any potential solutions to this issue or is this just an issue that was potentially fixed in 10.0?

       

      Any help or direction would be fantastic.

       

      Thanks,

       

      Aaron

        • 1. Re: Tableau 9.3.6 Mapbox blank map

          Hi Aaron Eisenbarth,

           

          If this mapping trouble is still occurring, I might have a solution for you.

          Tableau uses a SSL connection over port 443 to connect to our mapping servers. Could you please make sure you are allowing outbound connections over port 443?

          This article has some more details and tips: Web Proxy and Firewall Settings | Tableau Software

          • 2. Re: Tableau 9.3.6 Mapbox blank map
            Andy Piper

            Aaron,

             

            The same problem is currently preventing us from rolling out Tableau Server version 10.0.1 to our users. The issue is somewhat inconsistent -- some visualizations using MapBox maps work fine, others don't -- about 20 workbooks have issues, but another 20 do not. All MapBox maps in these same workbooks worked fine on Tableau Server 9.2.6.

             

            Changing the map layers and even adding new maps and republishing (overwriting existing as well as using new names for the dashboard) did not correct those visualizations that are having problems. The maps that do not appear in a viz on server show up just fine in Desktop 10.0.1. The same MapBox map used within a different viz may work just fine in Server 10.0.1 -- that's so perplexing. Based on that, it appears to be something at the workbook level (what I don't know yet).

             

            I'm about to try recreating one of the workbooks from scratch to see if it will start working. If that is successful, might there be something in the XML that could be searched for to find a difference between those workbooks that show the map correctly on server vs. those that do not?

             

            Andy

            1 of 1 people found this helpful
            • 3. Re: Tableau 9.3.6 Mapbox blank map
              Andy Piper

              Aaron,

               

              I was able to recreate the issue in a brand new 10.0.1 workbook and publishing it to the 10.0.1 server. In this particular visualization, there were a many fields on the Detail shelf. Through process of elimination, it appears that if the field added to the detail shelf would create multiple marks on top of each other, the map would go away on server. I was able to test this easily by just editing the view on server after publishing it.

               

              In my case, I had train stations displayed on a map along with some additional information about the train stations. Once I added a field (call it train_id) to the level of detail, the map failed. Could it be disappearing because now there might be 6 marks (or trains) at that location? If instead I add the same field to the Tooltip shelf, the map would continue to display for only one mark is present -- the tooltip would show train_id as an asterisk (*). Quite odd.

               

              I've tried taking maps that are working and seeing if I can get them to fail by adding more dimensions to the detail shelf; but I can't get them to fail yet. I also have a case where the map (in a worksheet by itself) shows just fine on server; but if I include that same worksheet in a dashboard it fails.

               

              Strange days indeed; most peculiar.

               

              Andy

              1 of 1 people found this helpful
              • 4. Re: Tableau 9.3.6 Mapbox blank map
                Andy Piper

                New finding -- I mentioned earlier that the map displayed fine on server if in a worksheet by itself. I've also discovered that the map displays fine on a dashboard if by itself and with some chart types (like a bar chart); but if I add a data table, it fails -- see attachment.

                 

                This data is coming from a single Excel spreadsheet based on data from publicly available Army Corp of Engineers' maritime database. Other workbooks where the issue occurs for us uses data from Teradata and other corporate data sources (so I wouldn't be able to share those vids ).

                 

                Any ideas from the MapBox/Server experts on the forums?

                1 of 1 people found this helpful