12 Replies Latest reply on Nov 8, 2016 2:09 AM by Greg Gawinowski

    Tableau workbook stopped working on Tableau 10

    Liat Ferman

      Hi,

       

      I have an old tableau workbook , that used to work, and was using live connection to Amazon redshift DWH.

      I have noticed that it stopped working. when I enter tableau online (which is already upgraded to tableau 10) I see blank sheet.  When I enter it on my tableau desktop version 9.3. .. it works perfect.

       

      I think what caused this failure is tableau 10 upgrade because I have just tried to open the same workbook on Tableau 10 - desktop and it fails! while in my oldest version it works great! On the tableau 10 version, I see all my measures colored red, and there is no  'Measure values' shelf as in tableau 9. All the red-colored pills have the error: "The calculation 'calc_name' is invalid"

       

      see the differences below:

       

      Does anybody had the same problem? What should I do?

       

      Thanks!

        • 1. Re: Tableau workbook stopped working on Tableau 10
          Liat Ferman

          Figured out half a problem!

          Apparently, I'm not sure how, but I think it is related somehow to Tableau 10, on the new tableau version some of my old-report's numerical measured turned into text! Which made my whole report try to calculate sum of string etc. I have changed it manually.

           

          The other issue I have found is with table calculations- for some measure I can't use table calculation "compute using: table (down)" on tableau 10.0, and I used it on tableau 9.3.

           

          Its a terribly complicated measure, took me so long to make it work in the old report. it uses two nested table calculations. When I chose the table (Down) option on tableau 10 I get this error: "The calculation 'Transactions' requires a user defined aggregation of a non-aggregated formula"

          off course I have defined my nested table calculations, and there is a same question in this link , but it didn't help me... So, I hope you guys can help!

           

          Thanks again.

          • 2. Re: Tableau workbook stopped working on Tableau 10
            Federico Segura

            We are having a widespread company panic! Many of our workbooks are empty. They were all working in 9.3 and somehow 10 screw things up. I tried searching for text fields but they all seem to be numerical.

             

            I hope Tableau support finds a solution otherwise this can mean tons of hours lost

            • 3. Re: Tableau workbook stopped working on Tableau 10

              Hello both Federico Segura & Liat Ferman,

               

              Thanks for bringing this issue to our attention!

               

              Federico, it looks like someone in your organization submitted a support ticket and we currently have a technician investigating the issue.

               

              Liat, I would strongly recommend creating a support case at tableau.com/support/request so we can help get this settled.

               

              On an overall note, fear not! Tableau Online includes workbook revision history so we should be able to get workbooks back to the way they were. Let me know if you have any questions and of course, if I find out anything pertaining to the issue, I'll share it here.

               

              Thanks for your patience,

               

              -Diego

              3 of 3 people found this helpful
              • 4. Re: Tableau workbook stopped working on Tableau 10
                Brian Roberts

                I am having a similar problem.  Just upgraded to version 10 today and several of my workbooks open up blank - but not all of them.  Curious.  Don't know if this helps, but I sent the twb file to a colleague and when he opened it, he could see the tabs for the various sheets at the bottom but no data since he did not have access to it, whereas I only had a blank sheet, though it did show me all the right dimensions and measures.  Plus, at the top it was calling the workbook "Book1" instead of the saved name, like it had never been saved.  Go figure!  Also, I happen to be running Tableau under Windows 7.  Don't know if that would make a difference, but there you go.  Any help would be appreciated, particularly since I can no longer post anything on our server which has been upgraded to 10.  Please help!!

                 

                Brian Roberts

                BYU - Lee Library

                • 5. Re: Tableau workbook stopped working on Tableau 10
                  Liat Ferman

                  Brian Roberts, Federico Segura You can try what I did:

                  I am working with Tableau online who has already upgraded to 10.0 version and with tableau desktop 9.3. Lately, I downloaded the trial version of Tableau 10.0 desktop so I can compare two desktop versions.

                  I opened the Desktop 10.0 version and changed manually all the measures that somehow turned from numbers to strings back to numeric measures.

                  Then I uploaded again the report and it worked.

                   

                  For my problem with the table calculation- it somehow worked itself out. When I have uploaded the workbook I uploaded one Dashboard with errors on table calculations (I said I will deal with out after someone here will answer) and it suddenly worked the day after! I don't like this random errors in my reports so I'm patiently waiting for your updates Diego medrano

                  • 6. Re: Tableau workbook stopped working on Tableau 10
                    Federico Segura

                    Liat Ferman thanks.  We did some testing in our blank workbooks. It seems that the text field used as filters are causing the problem. We are working on a DB2 connection and it seems that Tableau 10 trims the content of text fields in the DB2 and Tableau 9 did not. For example a field that used to show STORE[3 spaces] now only shows STORE without any space. The workbook is filtering for a value that does not exist and that is why it shows the whole workbook blank.

                     

                    Solution: I dropped the text field, put it back as a filter and select the proper value (STORE) and worked. At this point that means that we still need to do redo out workbooks unless they find a solution for keeping the data structure the same way as in Tableau 9.3 Diego medrano

                    • 7. Re: Tableau workbook stopped working on Tableau 10

                      Hey everyone,

                       

                      Our dev team is still investigating the issue but it does look like the issue is related to trailing spaces. For now, a workaround seems to be to edit all calculated fields to include TRIM() information or to remove trailing spaces. I'll let you know if we get more info!

                       

                      Thanks again for your patience,

                       

                      -Diego

                      2 of 3 people found this helpful
                      • 8. Re: Tableau workbook stopped working on Tableau 10
                        Jonathan Goldberg

                        Just wanted to check in and see if there was any progress on this issue. We are currently assessing whether to upgrade to the current version of the software, or wait for an updated version.

                         

                        While there is a workaround, if its simply a matter of waiting a week or two for a fix we'd prefer to do that.

                        • 9. Re: Tableau workbook stopped working on Tableau 10
                          Brian Roberts

                          Jonathan,

                           

                          I don’t know if this will help, but I had a similar issue when I upgraded to version 10 that I finally submitted a help ticket with Tableau Support.  Here’s what I sent to our Tableau user community here at BYU as to the resolution of that issue:

                           

                          Just thought I’d share something with everyone that I’ve learned painfully over the course of the last few days after upgrading to version 10.  I don’t know if anyone else has had this problem (I haven’t seen anything come across the listserv), but I thought I’d share it just the same.  I have shared this with Sam McKnight (he actually helped me through a lot of the initial investigation of the problem), but he also has not heard of anyone else with this issue.

                           

                          Anyway, after I upgraded to version 10, with the exception of two workbooks, none of my files would open properly under version 10.  I finally submitted a help ticket to Tableau support and after several rounds of shoulder shrugging on their part, they did a WebEx with me today where we were able to “solve” (and I use that term loosely) the problem.  As it turned out, the fix was actually pretty trivial, but should not have been a problem in the first place, in my opinion.  At any rate, I want to let everyone know what that is so that if you are experiencing similar problems in version 10, you will know how to fix it.

                           

                          In the past, whenever you have upgraded Tableau, and then first open the upgrade, your Open window would be blank as all of your workbooks would not have been opened before in the new version.  I think any of us who have had Tableau Desktop now for a few years know what I’m talking about.  So, to access my workbooks in the new release, I would click on the “Other files” under Connect, select the workbook I would want to open, get the message warning me that the workbook would be upgraded when it is saved, and presto, it would open just fine.  However, in version 10 (and the latest version of 9.3 for that matter) when I tried the same thing, only this time the link said “More . . .” and not “Other files”, a window would pop up confirming the data source, and then it would open to a blank workbook but with the right dimensions and measures listed in the data pane.  Just no sheets or dashboards that I had created in the previous version.  It did that for every workbook in my “My Tableau Repository/Workbooks” folder with the exception of the aforementioned two, both of which opened as described in the first part of this paragraph.  And so you know, it didn’t matter if it was a .twb, .twbx, or any other tw-whatever file, with the exception of the two that worked, none of them would open.

                           

                          So, after demonstrating that with the support person during the WebEx call, he realized what the problem was.  Apparently, according to Tableau, you should not be using the path I described initially above to open existing workbooks in an upgrade of Tableau (or ever, for that matter).  Instead, you should either click on the good old “File – Open” path or the “Open a Workbook” link on the upper right hand side of the Start Page Open window.  That is the process that actually opens a workbook, where the other path is apparently only supposed to open a data source.  Hence, I would see all the information in the data source, but nothing in the workbook I had created from it.

                           

                          Hopefully that makes sense to you.  I admit, I was a bit surprised with the solution, but it did seem logical – to a degree.  At any rate, I hope this helps you in solving your problem.  If not, then I would suggest opening a help ticket with Tableau to see what they can do to help.  For me they were quick to respond.  Good luck!

                           

                          Brian C. Roberts

                          Process Improvement Specialist

                          Harold B. Lee Library

                          Brigham Young University

                          Provo, UT  84062

                          801-422-1989

                          brian_roberts@byu.edu<mailto:brian_roberts@byu.edu>

                          • 10. Re: Tableau workbook stopped working on Tableau 10
                            Ruthie Petty

                            Diego -- I don't see this listed on the Known Issues page. Is there an Issue ID assigned, or was the problem resolved in 10.0.1? Thank you!

                            • 11. Re: Tableau workbook stopped working on Tableau 10

                              The defect number is 566232. The fix is currently slated for a future maintenance release, most likely 10.0.3 but there's no guarantee and these things are always subject to change.

                              3 of 3 people found this helpful
                              • 12. Re: Tableau workbook stopped working on Tableau 10
                                Greg Gawinowski

                                Is there any date on 10.0.3 release? We recently upgraded from 8.0.1 to 10.0.1 and thank God we upgraded the dev server only not the live one. Our workbooks which worked perfectly in v8 are not working as intended in v10 and there is simply no way I could go through them all and make corrections. We wanted to upgrade to v10 before our next major relase so having a general idea of the next patch release date would be great.

                                Many thanks,

                                Greg