4 Replies Latest reply on Jul 28, 2016 4:54 AM by Mark Fraser

    Tableau hangs on 'Executing Query' after upgrade to 9.3.4

    Rory McQueeney

      Hi there,

       

      We use Tableau Desktop and Tableau Reader in the office and have recently upgraded both to the new versions.

      A few of the dashboards that we've created are now not working after the upgrade where they worked fine before in the previous version.

       

      If I try to open one of the workbooks using Desktop it will start the process but gets to 'Executing Query' and then just hangs (I've left it for as long as 45 minutes and it still didn't proceed any further). Previously it would open in under a minute.

      Similarly, using Reader to open the packaged workbook file that was created using the aforementioned workbook then it seems to open ok but then hangs as soon as you try to change any filters, again sticking on 'Executing Query'.

       

      The workbook causing most issues uses an excel file as it's data source that's 14MB in size. There are a number of quick-filters set up in it as well as calculated fields, charts and graphs all of which were working fine in the previous version of Tableau Desktop and Reader.

       

      I've tried uninstalling both Desktop and Reader and re-installing but the same problem persists.

       

      Does anyone have any suggestions as to what the problem may be and how to fix it?

       

      Thanks