5 Replies Latest reply on Aug 2, 2016 11:43 AM by Santiago Calvo

    How can I do to prevent   the words are separated into lines?

    Santiago Calvo

      Hello,

       

      I´m having problems with the format of texts.

       

      I don´t know how to prevent the words to get separated into lines, sometimes I use the "Enter key". It works but when I change to another computer, the adjustment get lost despite I work with the dasboard in "automatic"...

       

      Know any way to solve that problem?

       

      Thak you,

      Santiago

        • 1. Re: How can I do to prevent   the words are separated into lines?
          Joe Oppelt

          Texts in Text Boxes?  In Title?  In Tooltips?  In a data point on your sheet?

           

          Maybe some screen shots would help.  Even better, create a bogus workbook using Superstore to show what you are doing.

          1 of 1 people found this helpful
          • 2. Re: How can I do to prevent   the words are separated into lines?
            Santiago Calvo

            Joe,

            Thaks for answearing

            My problem is with texts in boxes. I need that the words don´t get separated in lines.

            Here there is an example of words that got separated in lines, in red color I show entire word.

            Thank you,

            Santiago

            1 of 1 people found this helpful
            • 3. Re: How can I do to prevent   the words are separated into lines?
              Joe Oppelt

              OK.  I see what you mean.

               

              Tableau is outsmarting itself here, trying to help you in ways you don't want to be helped.

               

              Part of the problem is the "Automatic" resizing from device to device.


              As you noticed, you can avoid hyphenation by setting your own carriage-returns, and by sizing the text box to match the way you laid out the "shape" of the text.  But that only works when your user is using the same sort of device you have created your dashboard layout on.  When someone pulls up your workbook on a different device, and when you tell Tableau to automatically resize, a proportional adjustment happens, and the text box may shrink, and the artistic layout you made gets all messed up.


              I never use "automatic".

               

              In our shop we use "iPad Landscape" for everything.  Our focus is to get users to take iPads to board meetings instead of reams of excel spreadsheets.  And we find that iPad Landscape looks very nice on laptops and desktops, so it's a very good solution for us.  We don't get resizing from device to device,  The dashboard design I create will look the same on just about everything someone uses to view it.

              1 of 1 people found this helpful
              • 4. Re: How can I do to prevent   the words are separated into lines?
                Vincent Baumel

                My department maintains a standard version and an iPad version, which is a point that really bugs me. The standard version was designed with Automatic sizing, and I found a good workaround to be setting it to a Fixed size, with dimensions equal to the automatic sizing. On my monitor, automatic is w1715 by h1031 - I just switch it from "Automatic" to "Exacty" and it retains the same dimensions. When I publish the dashboard, all of my filters, worksheets, and everything keeps the same relative sizing. It functions the same and looks just as good on a 120" 4k projector as it does on a small smartphone. It's been a REALLY nice solution to present, because we can design things on a big beautiful monitor and know exactly how they'll function on whichever device the users choose.

                1 of 1 people found this helpful
                • 5. Re: How can I do to prevent   the words are separated into lines?
                  Santiago Calvo

                  Vincent,

                   

                  Thanks for your help!

                   

                  I´ve tried what you said, Tableau maintains the shape of the text, but in automatic mode the text goes to the left..