13 Replies Latest reply on Oct 23, 2016 11:33 AM by tom jones

    Tableau Extract SDK error

    Dimitri.B

      I am trying to use Tableau SDK with a third party tool to produce a Tableau data extract.

       

      The process repeatedly fails with the following error, which (I am told) originates in the guts of Tableau SDK. Does anyone have any tips or ideas on how to diagnose it further?

       

      ERROR Tableau Writer (TDE) 0:8        Execute failed: Timeout
      - IPC_NamedPipe::Select(WaitForMultipleObjects)

       

       

       

      Thank you.

        • 2. Re: Tableau Extract SDK error
          Dimitri.B

          Thank you, Lester.

           

          This KB article is from 2014 and relates to versions 8.2.0 - 8.2.4, I am using SDK 9.3.3 and Tableau 9.3.4.

          • 3. Re: Tableau Extract SDK error
            Dmitry Chirkov

            Does it ever succeed? Are you able to do anything with SDK now or it fails like this no matter what you do?

            I looked into error and in few places where we had it we suspected/fixed missing dependencies.

             

            And minor question.. What platform and what language are you using?

            • 4. Re: Tableau Extract SDK error
              Dimitri.B

              Hi Dmitry,

              Thank you for looking into this.

               

              I am using KNIME Analytic Platform 3.2, which now has Tableau nodes. I believe it is based on Eclipse and uses Java internally. The node instructions specify that Tableau Extract SDK and Visual C++ redistributables must be installed and some environment variables configured, which I have done as per their instructions.

               

              I haven't tried testing the SDK by other means, and KNIME only provides two nodes. I'll try the KNIME server node and some variations of the local node (the one that fails) and post the results.

              • 5. Re: Tableau Extract SDK error
                Dimitri.B

                Tried both local and server nodes with different data - same result, same error message.

                • 6. Re: Tableau Extract SDK error
                  Dmitry Chirkov

                  Knime's support say anything? I guess it's here.

                  Can you find and share any logs?

                  Can you find tdeserver64.exe and launch it from command line? Can it launch by itself?

                  • 7. Re: Tableau Extract SDK error
                    Dimitri.B

                    That's correct, KNIME forum guys said the error is from Tableau SDK. The log entries are attached to that thread.

                    Let me know if you need full logs or anything else.

                     

                    I can run tdeserver64.exe from command line, here is the output:

                     

                    tdeserver output.png

                    • 8. Re: Tableau Extract SDK error
                      Dmitry Chirkov

                      Let's take this offline.

                      Shoot me an email at dchirkov alias.

                      • 9. Re: Tableau Extract SDK error
                        Dmitry Chirkov

                        We worked this out with Dimitri offline - he had two different versions of API/SDK installed on his machine and both of them were listed in PATH variable.

                         

                        Solution: remove the old API/SDK folder (in this case it was 9.0 so incompatible with version KNIME is using in their client) and remove it's reference from PATH.

                        1 of 1 people found this helpful
                        • 10. Re: Tableau Extract SDK error
                          Rob Stubbs

                          I believe I am having the same issue -- at least a related one.  I installed the 32-bit Windows Tableau SDK on Windows 10 and get the following error when trying to run even any of the python samples that are included in the SDK:

                           

                          TableauException (40200): IPC_NamedPipe::Select(WaitForMultipleObjects): Timeout

                           

                          Before the error appears, a modal dialog pops up with the message: "tdeserver64.exe - Application Error"  -- "The application was unable to start correctly (0xc000007b).  Click OK to close the application."

                           

                          I do have a tdeserver32.exe in the build directory Why isn't it looking for tdeserver32.exe?  Should I look for something in particular in my PATH variable?  And in case it helps, I do see a 64-bit version of the SDK on the machine, so it is entirely possible that I installed that one before realizing I was using a 32-bit version of python.

                           

                          tdeserver32.exe is in C:\Program Files (x86)\ActivePython_2.7.8\Lib\site-packages\tableausdk\bin

                          tdeserver64.exe is in 2 locations:  C:\Program Files (x86)\ActivePython_2.7.8\Lib\site-packages\tableausdk\bin and C:\Program Files\Tableau\Tableau 10.0\bin

                          • 11. Re: Tableau Extract SDK error
                            tom jones

                            I too am having the exact same issue and wondered if you could help me.  I did a clean install of tableau sdk (windows 32bit) and an install of tableau desktop.  I'm attempting to use it with python but can't for the life of me get it to work.

                             

                            tableausdk.Exceptions.TableauException: TableauException (40200): IPC_NamedPipe::Select(WaitForMultipleObjects): Timeout

                             

                            I get the same error with everything I change.  Would really appreciate some help.

                            • 12. Re: Tableau Extract SDK error
                              Rob Stubbs

                              I eventually got my setup working by adding the path to tdeserver64.exe to my PATH environment variable.  I did not figure out why it was looking for tdeserver64.exe and not tdeserver32.exe, but I didn't spend much time investigating.  I was happy that I got it working and haven't had any troubles sense.

                               

                              Since I had downloaded the 64-bit Windows Tableau SDK first, my path is actually pointing to the tdeserver64.exe where I extracted that SDK.  I suspect it would work if I had included the Desktop install path instead, i.e., set PATH=%PATH%;C:\Program Files\Tableau\Tableau 10.0\bin

                              1 of 1 people found this helpful
                              • 13. Re: Tableau Extract SDK error
                                tom jones

                                Thank you! For whatever reason I wasn't getting the error and ended up redownloading it.  I tried with tableau 32bit but even with everything in 32, it was still searching for tdserver64.exe.  I ended up downloading tableau desktop 64 and then added the path like you said and everything started working!