7 Replies Latest reply on Apr 27, 2016 11:13 PM by Mahfooj Khan

    Failing to load all countries

    asch harwood

      I am trying to load data for all countries in sub-saharan Africa.

      https://public.tableau.com/views/SSTDraftApril242016/FinalSST?:embed=y&:display_count=yes&:showTabs=y

       

      I have intentionally excluded Algeria, Morocco, Tunisia, Egypt, and Libya using the filter function in the source data application.

       

      You can see in the first screen shot, that the data set includes for 49 countries, 44 of which I would like to include on the map.

       

      However, Tableau is failing to load data for about 16 countries.Screen Shot 2016-04-24 at 20.43.09.png

       

      When I click on the country column and then describe, it is only showing 28 countries:

      Screen Shot 2016-04-24 at 20.43.34.png

       

      Any ideas why it isnt pick up the other 16 countries?

       

      Thanks in advance!

       

      Asch

        • 1. Re: Failing to load all countries
          Ashish Chaudhari

          Hi Asch,

           

          Can you provide data download access for this viz, so that I can go through the same?

           

          I tried opening the workbook but its created in 9.3 version. I have tableau 9.2.

           

          Let me know if you can provide the data download access. I will be glad to help you out with the problem.

           

          Thanks and Regards,

          Ashish Chaudhari

          • 2. Re: Failing to load all countries
            asch harwood

            This gets even weirder. I have the data download enabled, but for some reason Tableau is not allowing the data to be downloaded.

             

            See Screenshot SST Draft April 24 2016 - CFR Niigeria Security Tracker | Tableau Public

            Any other options?

             

            Asch

            • 3. Re: Failing to load all countries
              Ashish Chaudhari

              Hi Asch,

               

              Even I have enabled the data download to some of my workbooks but I wan't able to download the same when my friends ask me to show the data. There is something wrong with it. Looking into your query.

               

              I have downloaded the workbook, since its a 9.3 workbook I am unable to open the same on my pc since I m using 9.2

               

              I am making a note on the community that there is a problem on data download feature of the tableau public.

               

              Mahfooj Khan, can you look in the same?

               

              Thanks and Regards,

              Ashish Chaudhari

              • 4. Re: Failing to load all countries
                Mahfooj Khan

                Hi Asch,

                Thanks @Ashish for pinging!

                 

                I've few questions kindly explain. If you see the first screen shots of edit data source filter details then you can understand may be due to data source filter this is happening.

                In your filters:

                Country filter looks fine.

                I've doubt on year filter. I'm not getting what you've filtered here? I've viewed your Year data its like 2011,2012 and so on.

                If you filter on year the it will be something like this.

                And one more if you're showing all the values from Event Date field then what's the uses of putting it in data source filter.

                I suggest. Just validate your data source filters once again. And can you share the remaining list of countries which are missing in the dashboard.

                Feel free to ask if you've any query.

                 

                Mahfooj

                • 5. Re: Failing to load all countries
                  Ashish Chaudhari

                  Hi Mahfooz,

                   

                  I think you have mistakenly replied me. I think you should copy the content of above msg and reply to Asch.

                   

                  Thanks for your view.

                   

                  Ashish.

                  • 6. Re: Failing to load all countries
                    Mahfooj Khan

                    Hi Asch,

                     

                    I've few questions kindly explain. If you see the first screen shots of edit data source filter details then you can understand may be due to data source filter this is happening.

                    In your filters:

                    Country filter looks fine.

                    I've doubt on year filter. I'm not getting what you've filtered here? I've viewed your Year data its like 2011,2012 and so on.

                    If you filter on year the it will be something like this.

                    And one more if you're showing all the values from Event Date field then what's the uses of putting it in data source filter.

                    I suggest. Just validate your data source filters once again. And can you share the remaining list of countries which are missing in the dashboard.

                    Feel free to ask if you've any query.

                     

                    Mahfooj

                    • 7. Re: Failing to load all countries
                      Mahfooj Khan

                      Thanks Ashish